Update: Microsoft will be moving away from UserVoice sites on a product-by-product basis throughout the 2021 calendar year. We will leverage 1st party solutions for customer feedback. Learn more here.

SQL Server

Microsoft SQL Server powers your entire data estate by supporting structured and unstructured data sources. It builds on previous versions of SQL Server, which have been industry leading for four years in a row and a leader in TPC-E. It scales to petabytes of data and allows customers to process big data through PolyBase using T-SQL over any data. SQL Server has also been the least vulnerable database during the last seven years. SQL Server brings data insights with business intelligence capabilities that provide analytics at a fraction of the cost on any device along with advanced analytics with support for R and Python.


More details about SQL Server are available in the SQL Server documentation.
If you have a technical issue, please open a post on the developer forums through Microsoft Q&A or Stack Overflow

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. Reporting Services Wizard generated Analysis Services Reports empty

    If i create an Analysis Services Report using the Wizard the whole datasource/Query empties if i try to modify the report.

    0 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  2. Restore of transaction log fails using Management Studio

    If the transaction log contain multiple files some before and after when a full backup is taken then restoring using Management Studio fails. Transaction log can be restored using scripts but not use the GUI tool.

    0 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →

    Upvotes: 0

    <=-=Jun 20 2006 10:52PM=-=>

    This is probably the same bug as https://connect.microsoft.com/SQLServer/feedback/ViewFeedback.aspx?FeedbackID=124718

    <=-=Jul 27 2006 12:17AM=-=>

    Thanks for your feedback.

    It looks like recovering full back-up is done with RECOVERY option (which is default choice in Options tab) and then restoring transactional log is done, and that is why UI throws valid error message from Engine

    This should have been done by restoring full backup with NO RECOVERY option and then restore from UI the transactional logs to restore successfully.
    I tired it this way and it works fine.

    Thanks,
    Gops Dwarak

    <=-=Aug 8 2006 1:10PM=-=>

    Thank you again for submitting this report. We will look at fixing this issue in the next major release of SQL Server. In the meantime, there is a workaround. Here is the sequence of that we think is going on and what should happen.

    1. Take one or more backup of the…

  3. sp_help_job is executed evey time a job is viewed, can seriously delay display of job over a slow link

    Every time you view a job in SSMS it executes sphelpjob which returns the summary of all jobs to the client, irrespective of the job being selected. This results in the time taken to load the job details being delayed, espcially over a slow link with lots of jobs.

    With 1000 jobs (i.e. a report server) over a slow link 128kbs it could take ~1minute to display the job details page.

    I don't see why this call is needed. Its not called in with EM

    0 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →

    Upvotes: 10

    <=-=Jun 29 2006 3:47AM=-=>

    Thanks for reporting this issue and we are planning to address this in our next release.

    <=-=Jul 14 2006 4:22AM=-=>

    Surely this shouldn’t be closed until it is included in the next release. At which point it can be closed.

    <=-=Jul 17 2006 12:59AM=-=>

    Nice catch. This will be addressed in next service pack. Thanks

    <=-=Sep 18 2006 3:16PM=-=>

    I regret to inform you that we could not accomodate this bug in our next service pack. We will get another chance to address the issue in our next release.

    <=-=Nov 18 2007 3:30PM=-=>

    Sms,

    I have resolved this issue as a duplicate of bug 28715, which was reported earlier about delete but is the same issue.

    -Richard Waymire
    PM, SQL Server Agent

    <=-=Jun 17 2013 5:34AM=-=>

    Hi,
    Can you please tell me in which service pack does this has been addressed ?

    Thanks,
    Shivaji…

  4. GetSchemaDataSet browsing cubes returning 0 rows

    When querying an OLAP database for a set of cubes non are returned (only one cube is processed)

    0 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  5. Cannot assign a multi server job to a group of servers like in SQL 2000

    In SQL 2000 EM you can assign a multi server job to multiple servers by selecting a group. There is no option for doing this in SSMS.

    In SQL 2000 there is a button "Change..." that pops up a dialog where serevers can be selecetd individually or via a group

    0 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →

    Upvotes: 1

    <=-=Jul 3 2006 4:54AM=-=>

    Nice catch and thanks for reporting this.

    The current workaround of selecting individual servers should not block from using this scenario;however, this is little time consuming if there are various servers and some are grouped. We are planning to get this addressed in the next release.

    Once again thanks for reporting this bug.

    Thanks,
    Gops Dwarak

  6. SSIS Error when debuging script task

    I have a script task with a break point. I was able to successful debug this script for a few hours, then I began having problems. First, the debug editor would come up, but I would not have any control. I waited a minute or so then when back to VS and stop debugging. The debugger closed, but I would get the error "MVSA has lost link to .". I could ok that message and debug again with success. After an hour or so, I started getting another message. This was a Just-In-Time debugging window stating that there was an…

    0 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →

    Upvotes: 1

    <=-=Jan 24 2008 9:48AM=-=>

    Hi, we are processing this bug and want to get more information from you so as to proceed. Here are our questions: 1) did it happen again or just once? 2) What version of SQLBuild you had on your machine? Which SKU (standard, enterprise, evaluation…)? If you can collect call stack information and send to us, that will be even better. Thanks for using Microsoft product, and looking forward to hearing back from you.

  7. RSClientPrint in reporting services errror

    This is a urgent needed for help... i got to put the release the application to a client but i can't while this problem isn't resolved...

    There is:
    When i try to print a report using RSClientPrint ActiveX object it give's me a error in the end of the request, but the report it's printed ok (just the error message appears)

    in attachement goes 2 files: report1.rdl and the printtest.htm

    0 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →

    Upvotes: 9

    <=-=Mar 28 2006 3:24PM=-=>

    I am not able to repro this issue. Here are a few things to try:

    Make sure you are using the SP1 print control. Your html still has the RTM version 1399 and should have the SP1 version you are using.
    Turn on the print control logging by setting the following registry value:
    [HKEY_CURRENT_USER\Software\Microsoft\Microsoft SQL Server\80\Reporting Services]
    “LogRSClientPrintInfo”=dword:00000001

    This will create a log file in the temp directory called LOG.tmp. Send this file to us, it should have some information to help us debug the issue.

    <=-=Mar 29 2006 8:12AM=-=>

    Are you using the Reporting Services 2005? And the rsclientprintcab that comes with that?
    And, what SP1 Print control that you are talking? I don’t know any, and i tryed to find in the web and don’t found (for this version).

    The registry key that you gave me isn’t for reporting services 2000?…

  8. Too many default permissions for the guest account in the master/msdb databases

    When you create a SQL login with just access to a user database (say AdventureWorks), with the default permissions, the login is able to run many command like:

    SELECT * FROM master.sys.objects
    exec spconfigure
    use master
    exec sp
    help

    etc. There is no reason why a user with minimal permissions on the system should be able to run a command like sp_configure or select all objects from the catalogs.

    0 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →

    Upvotes: 2

    <=-=Jan 18 2006 2:28PM=-=>

    We are looking into if we can limit those accesses.

    <=-=Oct 31 2007 11:35AM=-=>

    After some investigation, we will not be considering this DCR. Although PUBLIC is able to perform the actions that you’ve mentioned, please keep the following in mind:

    1. Most of the procs do permission checks internally. So even though public has execute permission, when they execute procs they get Access Denied errors.
    2. Even though public has select permission on Catalog Views, we have Catalog security that displays only the objects on which the user has permissions.

    Thank you and we appreciate your input

  9. BEGIN STACK DUMP - Non-yielding Scheduler

    This is an addition to Bug ID 279369. We are getting the same error in Sql Server 2005 SP2 version too.
    The dump files are attached.

    0 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →

    Upvotes: 0

    <=-=Dec 17 2007 2:01PM=-=>

    Dear Customer,
    Thanks you very much for taking the time to send us feedback. We have looked at and understood the bug and are working on a fix. We will keep you updated on the progress.
    Best regards.

    <=-=Dec 13 2010 9:36AM=-=>

    Dear Customer,

    Please forgive the rather long wait for a followup, this fell between the cracks. The issue reported was fixed in SQL 2005 build 09.00.3200.00 which shipped in 2008. Any recent Service Pack or Cumulative Update thereof has the fix.

    Campbell, SQL Development

  10. Non-Yielding Scheduler, Minidump, and

    During a fairly high workload, received errors indicating non-yielding scheduler and three worker thread "Worker 0x1EFEA0E8 appears to be non-yielding on Scheduler 3" messages in the SQL event log.

    Also received, in the Windows Event Log (Application):
    App: E 'Wed Nov 14 22:38:02 2007': Application Hang - " Hanging application tdpsql.exe, version 5.2.1.4,
    hang module hungapp, version 0.0.0.0, hang address 0x00000000. "

    Initial analysis of minidump indicates that the worker thread was doing some sort of nested loop join and at time of crash was in "sqlservr!LatchBase::ReleaseInternal", which was called by XVB::GetRecord. Minidump and dump logs are attached to this…

    0 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →

    Upvotes: 0

    <=-=Feb 4 2008 1:22PM=-=>

    Thanks for identifying the issue. We will look into it and get back to you with the resolution.

    <=-=Mar 17 2009 6:53PM=-=>

    this issue has been identified and fixed. The fix is available in YUKON/SP2 and YUKON/SP3 CUs. Please go for the latest CUs. For questions, please feel free to contact us

    thanks
    Sunil

  11. Custom Data Processing Extensions Don't Show in the Standalone Report Designer

    Custom Data Processing Extensions don't show up in the Standalone Report Designer.

    0 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →

    Upvotes: 1

    <=-=Jan 31 2008 7:28AM=-=>

    Thank you for using SQL Server Reporting Services. We are investigating how best to partner extensibility features with the Stand alone desiger. The timeline for that is currently not set. Thank you for your patience.

    <=-=Jul 7 2008 12:09PM=-=>

    Custom data processing extensions will not be supported by Report Builder 2.0 (updated name for standalone report designer) when processing in local mode (not using a server resource). We are considering adding support for processing on the server to get capabilities such as custom data processing extensions. If this would solve your use case, we would love to hear feedback. Thanks.

  12. SSRS 2008 Strange behaviour of charts with a Report Server Model as datasource

    I made a few tests on the November CTP, especially with the Report Server Model as datasource in the Report Designer Preview.

    I use the Adventure Works Samples for SQL 2008 found on Codeplex and did quite simple tests : a table displaying the sales grouped by year and by product category, and the histogram chart that corresponds.

    I have found strange things with the charts : sometimes the values they display are not the good ones. They are all equal to 1, even if the table still displays the good values.

    To compare, I made the same thing with…

    0 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →

    Upvotes: 1

    <=-=Jan 7 2008 8:02PM=-=>

    Thank you for the feedback.

    In CTP November, the RDL metadata tags created by the report designer preview for model-based queries are incorrect in this case. It detects System.String, when it should have detected System.Int32:

    Total Order Quantity System.String

    If you change this in the RDL manually, the drag and drop behavior will change and the default aggregate generated for chart data points will use =Sum(…), instead of =Count(…).

    That’s why you get the output you are seeing right now. Alternatively, you can also manually modify the generated aggregate function for the chart data point in report designer.

    Consequently, when you drag and drop that field into the chart data field, the designer generates a =Count(…) aggregate. However, if the metadata tags were correct, it would generate =Sum(…) and the chart would work as expected at runtime.

  13. Syntax BOL regarding Multi Insert is wrong

    In BOL the example for Multi Insert (B under Insert) is wrong.
    It is now:
    USE AdventureWorks;
    GO
    INSERT INTO Production.UnitMeasure
    VALUES ((N'F2', N'Square Feet', GETDATE()),(N'Y2', N'Square Yards', GETDATE()));
    GO

    It should be:
    USE AdventureWorks;
    GO
    INSERT INTO Production.UnitMeasure
    VALUES (N'F2', N'Square Feet', GETDATE()),(N'Y2', N'Square Yards', GETDATE()); -- Deleted ( and )
    GO

    0 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  14. ReportServer and Report Manager do not work well with Vista and UAC unless UAC is disabled

    In Windows Vista, when trying to access the Report Manager web application in order to manage report catalog content, or when trying to deploy to a Report Server using BIDS, the UAC prevents local administrators from accessing Content Manager objects and features. It renders the report server pretty much useless unless UAC is disabled.

    0 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →

    Upvotes: 2

    <=-=Jan 8 2008 2:34PM=-=>

    Thank you for filing this issue. Using Reporting Service in conjunction with UAC is somewhat difficult the first time you try it. Once you configure the roles correctly and add the report server URLs to Trusted Sites in IE, it work significantly better. Please review the following support article for comprehensive steps:
    http://support.microsoft.com/kb/934164/en-us

    We will consider this as we plan the remainder of SQL Server 2008.

    <=-=May 6 2008 9:48AM=-=>

    Thank you for filing this issue. Though it is tricky the very first time a user uses SSRS on Vista/Windows Server 2008, the scope of the change required to address the issue is too large for us to make a change as part of the SQL Server 2008 release. We will consider it for a future release.

    Thanks,
    -Lukasz

  15. MSFT - Maddog: Exec MachineRequestSelect is slower in Katmai

    One of the three most used Maddog sprocs that is slower in Katmai when compared to Yukon.

    0 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →

    Upvotes: 0

    <=-=Dec 17 2007 3:01PM=-=>

    Josh,
    The defect is currently under investigation. We will keep you updated on the progress.
    Thanks and best regards.

    <=-=Jan 22 2008 11:33AM=-=>

    Josh,
    We found out that this bug is a duplicate of “MSFT – Maddog: Exec MachineRequestSelect is slower in Katmai” (307401), which is still under investigation.
    Best Regards,
    Roman

    <=-=Jan 22 2008 1:22PM=-=>

    You just duped this bug to itself. Is there a different bug you’re referring to? Or should this bug still be active?

  16. MSFT - Maddog: exec dbo.ResultInitialize is slower in Katmai

    One of the three most used Maddog sprocs that is slower in Katmai when compared to Yukon.

    0 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →

    Upvotes: 0

    <=-=Dec 17 2007 3:00PM=-=>

    Josh,
    The defect is currently under investigation. We will keep you updated on the progress.
    Thanks and best regards.

    <=-=Jan 10 2008 9:41PM=-=>

    Hi Josh, we are still investigating this issue. Right now, we are looking at cernrates in the storage engine to determine the potential root cause of the slowdown.

    Thanks,
    Torsten Grabs
    SQL Server Program Management

    <=-=Feb 19 2014 5:59PM=-=>

    We are closing this defect as ’won’t fix’. Please feel free to re-open it if it continues to be an issue

    thanks
    Sunil

  17. 2008: DUTT: Does not restore master DB or restore original logins for replay

    The master database was backed up from production databases in the previous release of DUTT for the purpose of extracting logins information. Profiler replays transactions in the context of the user connection Profiler is connected to SQL Server with, not the actual logins in the captured trace file. This works fine in most situations except when the database uses a schema other than DBO. In this case, the logins that map to database users with the default schema set to something other than DBO will not exist during replay. SA and Local Admin always maps to DBO by default. If…

    0 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →

    Upvotes: 0

    <=-=Feb 18 2008 6:52AM=-=>

    Hi Joe
    Rebecca will work with you on this one.

    <=-=Apr 29 2010 1:55AM=-=>

    Hi Joe,

    We will evaluate this in the next major release of SQL Server as we think about the next generation of DUTT.

    Shirley Wang
    Microsoft SQL Server Program Manager

  18. Full Text Installation Failure

    Installation of SQL Server 2008 November CTP on Win 2008 RC1 leaves full text capability disabled.

    0 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →

    Upvotes: 0

    <=-=Dec 18 2007 7:24PM=-=>

    Sorry you are hitting this issue and thanks for reporting it. When you say “Create Database screen” what are you referring to?

    <=-=Dec 19 2007 4:00AM=-=>

    Open SQL Server Management Studio, right-click Databases in Object Explorer, select New Database

    <=-=Dec 20 2007 6:19PM=-=>

    Sorry I am unable to reproduce the problem. Can you please attach the setup logs which are by default located under “Program Files\Microsoft SQL Server\100\Setup Boostrap\Log\”?

    <=-=Dec 22 2007 6:40PM=-=>

    Screen shots and log files attached

    <=-=Jan 19 2008 11:34PM=-=>

    I apologize for the delay. We have been unable to reproduce this problem. After install we are able to successfully create a database with Full-Text enabled. Can you try running the following SQL statement and let me know if this returns 1 (indicating that Full-Text is installed):
    SELECT FULLTEXTSERVICEPROPERTY

    Also do you see the SQL Server Full-Text Search service…

  19. CTP5 - Error when editing Backup Task in Maintenance Plan on 1/16/2008

    When the computer date set to 1/16/2008, trying to edit the Backup Task in Maintenance Plan, I'm getting the following error:

    Value of '1/16/2008 12:00:00 AM' is not valid for 'Value'. 'Value' should be between 'MinDate' and 'MaxDate'.
    Parameter name: Value (System.Windows.Forms)

    After I change the computer date to 1/17/2008, it works ok.

    0 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →

    Upvotes: 0

    <=-=Apr 16 2008 8:37PM=-=>

    Hi Ayad,

    This issue has been fixed, and we feel it is fixed in ctp6 itself. Kindly let us know if you think otherwise. Thank again for reporting this issue. We appreciate your concern and effort in helping us improve the quality of SQL Server.

    Regards
    Vinod

  20. MSFT-MSO: System SPs and Functions firing a lot of 'Deprecation' events in profiler, makes it tough to identify the events fired b

    System SPs and Functions firing a lot of 'Deprecation' events in profiler and this makes it extremely difficult to identify the events fired by user created objects.

    My objective was to run a trace and figure out if we're referring/using any objects that are going to be deprecated - But system objects firing a lot of deprecation event is too annoying. What's even more spamming is that, the very frequently used SPs like sphelptext, spdepends do fire lot of this event.

    I think it would be great if we start using the new replacements in our system SPs,…

    0 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →

    Upvotes: 1

    <=-=Jan 22 2008 11:31AM=-=>

    Hello,

    Thank you for sending us your feedback. We are aware of this issue and are working on a solution for this. However, it is quite tricky to solve this. We can either spend a lot of efforts in the current release (SQL Server 2008) and get rid of all internal dependencies or enhance our deprecation messages to not fire if the usage is internal.

    Once we decide on the solution, we will get back to you. If you have any suggestions, feel free to send them to us.

    Thanks,
    -Vineet Rao.

  • Don't see your idea?

SQL Server

Categories

Feedback and Knowledge Base