Do you have a comment or suggestion to improve SQL Server? We’d love to hear it!

Separate connections using filtered nonclustered columnstore index on #temp table blocks (bug)

Two batches on two separate connections execute the same stored procedure. In the stored procedure, if you create a filtered nonclustered columnstore index on a #temp table (for batch mode), one of the batches will get blocked.

If you remove the filter from the NCCI, there is no blocking.

5 votes
Sign in
(thinking…)
Password icon
Signed in as (Sign out)

We’ll send you updates on this idea

Ned Otter shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

1 comment

Sign in
(thinking…)
Password icon
Signed in as (Sign out)
Submitting...
  • Ned Otter commented  ·   ·  Flag as inappropriate

    I wanted to be clear that this issue is not specific to columnstore indexes - the exact same behavior (locking/blocking) happens if you use a nonclustered index. The issue is related to filtering.

Feedback and Knowledge Base