Do you have a comment or suggestion to improve SQL Server? We’d love to hear it!

SSAS Designer showing empty phantom/duplicate tables

Working with an SSAS multidimensional cube that was developed using SSDT 17.3, the Data Source View for the cube is showing multiple phantom tables as the data source view is changed/refreshed. This is happening when looking at the Data Source View for both cubes as well as dimensions.

The Data Source View object itself does not show any issues, cube functionality does not appear to be affected when it is deployed and processed.

When trying to use the "Copy Diagram from" function, Visual Studio crashes on me.

The issue has persisted as I've upgraded to 17.4, as well as testing with SSDT 15.x. This is a continuation of the issue described at https://social.msdn.microsoft.com/Forums/en-US/b4be5ff0-5b9f-4538-9ec0-5def3bab4fff/phantom-tables-in-ssas-cube-data-source-view?forum=ssdt

56 votes
Sign in
Check!
(thinking…)
Reset
or sign in with
    Password icon
    Signed in as (Sign out)

    We’ll send you updates on this idea

    Evan Morgoch shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

    14 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
      Password icon
      Signed in as (Sign out)
      Submitting...
      • shair commented  ·   ·  Flag as inappropriate

        "Solution" is the wrong word, it is a band aid, not a fix! Stupid we have to jump through hoops to make something work properly.

      • Anonymous commented  ·   ·  Flag as inappropriate

        SOLUTION!!!!...
        I have the same problem, very anoying. but there is aeasy way to fix it.
        1.- Right click on the cube and go to view code (F7).
        2.- Then on the first Annotation "DiagramLayout" delete all the <value> tag. you will have something like this.
        <Annotations>
        <Annotation> <Name>http://schemas.microsoft.com/DataWarehouse/Designer/1.0:DiagramLayout</Name>
        </Annotation>

        3.- Comeback to the Cube design view.... and Magic.... everything looks ok now.. and if you comeback to the xml again, the <value> tag inside of DiagramLayout was recreated.

      • Reza commented  ·   ·  Flag as inappropriate

        Same here on VS2015 SSDT: 14.0.61707.300 but it works in VS2017 SSDT: 15.1.61901.03220
        In other hand the main DSV doe refresh from database in VS2015 but does not work in VS2017.

        So we have both installed to be able to do 1 job. Not good at all Microsoft.
        Not acceptable.

      • Anonymous commented  ·   ·  Flag as inappropriate

        I see exactly same behaviour when adding new measures to an existing measure group. I tried both VS2017 and VS2015 same result, MS please look at this issue it's very confusing to work with.

      • Tawfiq commented  ·   ·  Flag as inappropriate

        This problem seems to have performance issues which needs to be fixed ASAP. Many thanks
        VS version : VisualStudioVersion = 14.0.25420.1

      • László Kiss commented  ·   ·  Flag as inappropriate

        OMG
        Totally same on
        Microsoft Visual Studio Professional 2015
        Version 14.0.25424.00 Update 3
        Microsoft .NET Framework
        Version 4.7.02558
        .
        .
        SQL Server Data Tools 14.0.60629.0
        and 2 years old issue

      • Rob commented  ·   ·  Flag as inappropriate

        Very annoying bug: after adding some measures, phantom tables appear and facttable contents are blank.
        Cube remains working but the view is unreadable and becomes a mess with phantom tables and empty facttables :-(
        I hope MS solves this asap.

      • Filip Sirucek commented  ·   ·  Flag as inappropriate

        I found out that duplicate fact table is always created after you add a new measure from the same fact table in the cube data source view. So many measures you add from the same table so many duplicate tables you will get. After you save and close cube designer the images of duplicate tables changes into blank frames with the same fact table name. There is no way how to get rid of these duplicate tables. When you need to move table or arrange the design you will see the duplicates hidden under the original fact table. Such a design is confusing and unusable.The only way how to make correct visual cube desing is to use cube wizard but once you need to add anything to this layout you have no chance to make it correct. I wonder why nobody have fixed this bug since 2015. This bug occurs in SSDT 2015 and also in 2017. Please fix this bug as soon as posiible. Thank you.

      • Anonymous commented  ·   ·  Flag as inappropriate

        This error/bug in SSAS makes the Cube data source view unusable. We need a fix for this issue ASAP.

      • Evan Morgoch commented  ·   ·  Flag as inappropriate

        Looking at the raw XML view in my cube, it looks like all the empty tables are a result of the multiple copies extra <ddscontrol> objects being added. An example of the full control is:
        <ddscontrol controlprogid="DdsShapes.DdsObjectManagedBridge.3" tooltip="MyTable" left="-83279" top="-15143" logicalid="230" controlid="1" masterid="0" hint1="0" hint2="0" width="6376" height="5000" noresize="0" nomove="0" nodefaultattachpoints="0" autodrag="1" usedefaultiddshape="1" selectable="1" showselectionhandles="1" allownudging="1" isannotation="0" dontautolayout="0" groupcollapsed="0" tabstop="1" visible="1" snaptogrid="0">
        <control>
        <ddsxmlobjectstreaminitwrapper binary="000c0000e818000088130000" />
        </control>
        <layoutobject>
        <ddsxmlobj />
        </layoutobject>
        <shape groupshapeid="0" groupnode="0" />
        </ddscontrol>

        The difference between these vs. a "real" one is that the <ddsxmlobj> tag is fully flushed out (ie. <ddsxmlobj>
        <property name="LogicalObject" value="dbo_factOE" vartype="8" />
        </ddsxmlobj>
        ).

        In my one dimension, I was able to "fix" it by manually removing all the trouble <ddscontrol> objects. However, trying to do the same in my cube caused it to crash. Presumably because there were also relationship lines in the cube that were pointing to those empty tables that were removed, rather than pointing to the real tables.

      • Anonymous commented  ·   ·  Flag as inappropriate

        Community 2017, version 15.7.5, has similar issues with tables that are completely blacked out in the Cube Structure view.

      Feedback and Knowledge Base