Do you have a comment or suggestion to improve SQL Server? We’d love to hear it!

Unable to attach to AzureGovernment cloud with SSMS 17

SSMS 17.4 offers the ability to connect to Azure storage, but it appears unable to connect to Azure Government tenants even if I explicitly select AzureUSGovernment in the Tools|Options|Azure Services option. I've tested this both in the object explorer and in file|open|Merge Audit Files dialogs. In both cases, I get an error message indicating that it's still trying to access the version on the enterprise AzureCloud:

The remote name could not be resolved: '__mystorageaccount__.blob.core.windows.net'

2 votes
Sign in
(thinking…)
Sign in with: Microsoft
Signed in as (Sign out)

We’ll send you updates on this idea

Jim Wooley shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

1 comment

Sign in
(thinking…)
Sign in with: Microsoft
Signed in as (Sign out)
Submitting...
  • AdminMicrosoft SQL Server (Product Manager, Microsoft Azure) commented  ·   ·  Flag as inappropriate

    so this is a bit lame but in SSMS 17.x you need to set this environment variable to the DNS suffix of blob storage for the cloud you want: AZUREBLOBDNSNAME
    The default is blob.core.windows.net.
    For US Government cloud I think you would set AZUREBLOBDNSNAME environment variable to "blob.core.usgovcloudapi.net"

    I think this is fixed in the SSMS 18 preview, can you try it there?

Feedback and Knowledge Base