SQL Server

Microsoft SQL Server powers your entire data estate by supporting structured and unstructured data sources. It builds on previous versions of SQL Server, which have been industry leading for four years in a row and a leader in TPC-E. It scales to petabytes of data and allows customers to process big data through PolyBase using T-SQL over any data. SQL Server has also been the least vulnerable database during the last seven years. SQL Server brings data insights with business intelligence capabilities that provide analytics at a fraction of the cost on any device along with advanced analytics with support for R and Python.

More details about SQL Server are available in the SQL Server documentation.
If you have a technical issue, please open a post on the developer forums through Stack Overflow or MSDN.


  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. Managed Connection Window doesn't update after changes

    When changing the authentication type between SQL Auth and Windows Auth it is not updated until you close and reopen the 'Manage Connections' window

    0 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  2. 'No Such Interface Supported' while trying to save maintenance plan

    While creating a simple maintenance plan, I cannot save it. When I click save, I receive the error 'No such interface supported.'

    0 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →

    Upvotes: 1

    <=-=Sep 21 2005 4:36PM=-=>

    Hello Jon,

    Thankyou for pointing out this issue to us. The scenario you described worked (we were able to save the maintenance plan) on all machines we have tried in our lab. The answers to the following questions can help us to repro your environment in our lab more accurately.
    1) Did you install Integration Services when you installed SQL Server 2005 and tools. For Maintenance plans to work you need install Sql Server Integration Services (SSIS) on the box on which you are trying to save the maintenance plan.
    2) Did this machine have previous versions of .Net framework or a previous version os SQL Server 2005. If so what steps did you take to uninstall that/those
    3) Could you provide an email address at which we can communicate easily.

    <=-=Jul 13 2009 6:49AM=-=>

    I am also having the same problem.…

  3. Multiple Monitors and SQL Management Connect box

    Connction dialog seems to take the largest monitor size for positioning, even if it is on a smaller screen

    0 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  4. Manually Created Maintenance Plans Failures

    I have done a couple test of the Maintenance plans and have been a bit confused by the results. I manually create a plan to run integrity checks, reorganize, full backups, cleanup old backups, cleanup history and log a success via TSQL. I am only doing this for system databases. If any part of the plan fails, it should log a failure via TSQL. When I run the plan, it reports that it completes successfully, but it doesn't actually appear to do anything. It does not log to the directory the plan is set to log to, no backups are…

    0 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →

    Upvotes: 3

    <=-=Oct 6 2005 12:44PM=-=>

    Thank you for your report . Can you please specify what CTP of Sql Server are you using ?
    We already fixed some issues for the Sep CTP build and plan to address some other issues in the first service pack.
    Radu Singer

    <=-=Oct 7 2005 10:52AM=-=>

    Dear mchamber,

    We would like to work with you and resolve any issues that you may have with creating new maintenance plans. Please send an email to nined@microsoft.com with details like what exactly was the maintenance plan doing. On what OS was the server installed? Were the maintenance plan scheduled?

    Regarding the part where you could not delete the backups you created using the wizard, it is a much sought after feature and we will definitely address that in Yukon-SP1

    -nimesh

    <=-=Oct 11 2005 12:48PM=-=>

    I am running the Enterprise Edition of the Sept CTP. The…

  5. Aggregate(Fields!Field.FormattedValue) fails

    Build a report on top of an MDX query such as:

    SELECT [Measures].[Internet Sales Amount] on 0,
    [Product].[Category].Members on 1
    from [Adventure Works]

    In a table in the body of the report use the following expressions. The first works in a detail row. The second works in the footer row. The third fails in the footer row.

    =Fields!InternetSalesAmount.FormattedValue
    =Aggregate(Fields!InternetSalesAmount.Value)
    =Aggregate(Fields!InternetSalesAmount.FormattedValue)

    You get the following error on that last expression:

    [rsInvalidCustomAggregateExpression] The Value expression for the textbox �textbox9� uses the function Aggregate with an invalid expression parameter. The expression parameter must be a simple field…

    0 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  6. Report Builder Filter Doesn't Set Default Member

    One would expect that setting a Report Builder filter to filter a given member would default that member but this is not the case. As a result, unlike Excel or OWC, any calculated members that depend on the current member of the Date dimension would require dropping the Date dimension explicitly on the Report Bulder report.

    0 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →

    Upvotes: 0

    <=-=Mar 2 2007 9:51AM=-=>

    Thank you for reporting this. It is an issue that is caused by the Report Builder query using subselects to apply the filter, and subselects don’t result in the current member being set. The query should include the member in the WHERE clause as well. I’m afraid the only workaround currently is to include the relevant attribute in the report.

    <=-=May 15 2007 12:24PM=-=>

    Thanks again for taking the time to report this issue. The bug has been marked such that it will be reviewed when we next make enhancements to this functionality.

    - Analysis Services Team

  7. run MDX query with parameters using OleDb

    I'm trying to run an MDX query against SSAS2005 with a parameter. It works fine with ADOMD.NET, but I can't get it to work using OleDb. (I have to use OleDb because of limitations of the calling application.) Is this possible?

    The following code works:

    //using Microsoft.AnalysisServices.AdomdClient;
    string MDX = "with member [Measures].[Test] as Str(@Param1) "
    + "SELECT [Measures].[Test] on 0, "
    + "[Product].[Category].[Category].Members on 1 "
    + "from [Adventure Works]";
    AdomdConnection conn = new AdomdConnection("Provider=MSOLAP.3;Data Source=localhost;Initial Catalog=Adventure Works DW;Integrated Security=SSPI;Persist Security Info=false;");
    conn.Open();
    AdomdCommand cmd = new AdomdCommand(MDX, conn);
    cmd.Parameters.Add("Param1", "abcde");
    System.Data.DataSet ds = new System.Data.DataSet();
    AdomdDataAdapter adp =…

    0 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →

    Upvotes: 15

    <=-=Jan 23 2007 1:50PM=-=>

    I believe your usage of parametrized query in OLEDB is not entirely correct. Please, refer to the following example:

    Having a query with a parameter such as “@typeParam” the following piece of code is necessary:

    46 Cmd.NamedParameters = True
    47
    48 Dim typeParameter As ADODB.Parameter
    49 Set typeParameter = Cmd.CreateParameter()
    50 typeParameter.Direction = adParamInput
    51 typeParameter.Name = “typeParam”
    52 typeParameter.Value = 2
    53 typeParameter.Type = adInteger
    54 typeParameter.Size = 4
    55
    56 Cmd.Parameters.Append typeParameter

    The following steps are important when using parameters with the OLE DB provider for Analysis Services:

    The Command must be notified to use named parameters (line 46). The OLE DB provider for Analysis Services only supports named parameters.
    The parameters must have a name that matches the indicator used in the query, less the @ prefix (line 51).
    Only input parameters are supported (line 50).
    Type and Size of…

  8. In Management Studio usability of colum name editor for Create Table screen is broken.

    Column name editor (inplace and in column properties window) has strange logic (I understand it, but it's not what user wanted from it).
    1. For columns containing sequence of " quotation marks:
    1.1 When user enter name " - he receive correct escaped name ["]

    1.2 When user enter name "" - he receive error:

    Microsoft SQL Server Management Studio

    The name '""' is invalid because it is empty, contains invalid characters, or contains more than 128 characters.

    OK Help

    But must receive [""] name.
    1.3 When user enter name """ (three characters) - he receive ["] as in 1.1…

    0 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  9. Unable to delete row using Results pane, when table contains columns which require escaping

    If table contains columns with names, which require escaping like ", user cannot delete row from such table using Results pane.
    It will receive error messages:

    Message one:

    Microsoft SQL Server Management Studio

    No rows were deleted.

    A problem occurred attempting to delete row 2.
    Error Source: .
    Error Message: Unable to parse expression.

    Correct the errors and attempt to delete the row again or press ESC to cancel the change(s).

    OK Help

    Message two:

    Microsoft SQL Server Management Studio

    No rows were deleted.

    A problem occurred attempting to delete row 3.
    Error Source: mscorlib.
    Error Message: Length cannot be…

    0 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  10. Error message when trying to edit data in table using Results pane, when table contains columns names, which must be escaped

    Trying to edit data in table containing columns with name, which require escaping (e.g. ") result in error.

    Error message one:

    Microsoft SQL Server Management Studio

    No row was updated.

    The data in row 3 was not committed.
    Error Source: mscorlib.
    Error Message: Length cannot be less than zero.

    Parameter name: length

    Correct the errors and retry or press ESC to cancel the change(s).

    OK

    Error message two:

    Microsoft SQL Server Management Studio

    No row was updated.

    The data in row 1 was not committed.
    Error Source: .
    Error Message: Unable to parse expression.

    Correct the errors and retry or

    0 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  11. Unable to change autogrowth

    I cannot via SSMS change the autogrowth setting for a database. It is currently set to restricted and I want it set to unrestricted. I make the change, click ok and no error appears but when I open it again the change is not there.

    I also tried creating a new database and noticed that the autogrowth setting of unrestricted is not copied from the model db to the new one.

    0 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →

    Upvotes: 2

    <=-=Feb 8 2007 1:41PM=-=>

    HI Giggles220,

    Thanks for reporting this issue. We have considered this for the future releases.

    Regards
    Vinod

    <=-=Jun 5 2007 7:19AM=-=>

    To add to the above thread..
    The issue is not with all databases.. it is not consistent. For some databases it saves appropriately but for some it is not. I have seen mostly it is happenning on Tlog files. Also it is saving it as * restricted to 2 + TB *.

  12. sp_executesql - InvalidOperationException: Handle is not initialized.

    When we execute two sp_executesql procedures (see steps to repro) which both use the same parameters (@Role) with same UDT (IntArray) and in the second execution the parameter is NULL, then exception "System.InvalidOperationException: Handle is not initialized" occurs.
    When we rename one of the parameters to @Role2, the exception dissappears.
    When we use other value than NULL for second call, the exception dissappears.

    0 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →

    Upvotes: 3

    <=-=Feb 6 2007 11:33AM=-=>

    Hi,

    Thanks for raising this issue. Although it does not make the bar for SP2 at this point, we are tracking it for future release of SQL Server. I’ve copied the bug and resolving the original as postponed.

    Regards,
    Tomer Verona
    SQL Server Development

    <=-=Feb 7 2007 3:30AM=-=>

    What is the connect-ID of the “copied bug”? Where can I track it? This problem is critical for out business-layer and we have to make some obscure workarounds…

    Robert Haken
    MVP ASP/ASP.NET

    <=-=Nov 20 2009 3:44AM=-=>

    We are still fighting this problem.
    Can you please provide the connect-ID of the issue, where can I track the status and see some solution?

  13. XmlaWarningCollection is empty on AMO calls

    I'm trying to do an unattended cube processing using AMO, and I simply want to let the user know that warnings and errors occurred (and how many of them) without necessarily stopping the process.

    Looking at the Cube.Process method overloads, you'll find out that it is possible to pass an XmlaWarningCollection that, allegedly, should return a warning collection populated with them.

    When coding that, the collection is always returned as an empty one (0 items). Again, I'm suspicious that only warnings are allowed and not XmlaError objects or generic XmlaMessages, guessing that I'm misunderstanding the issue.

    In the MSDN forums: …

    0 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →

    Upvotes: 7

    <=-=Feb 8 2007 10:53AM=-=>

    Thank you for reporting this issue. We will investigate and get back to you.

    <=-=Mar 3 2007 3:48AM=-=>

    I think I would like to see the option in the xmla process command to ask for a verbose list of the warnings to be returned in the xmla response.

  14. MSIT - MSO: SGAM contention in CTP3

    This is mostly a placeholder for now. Problem is being investigated with CSS.

    We do not have -T1118 but we did not need it either. Way back when we have tested our workload with and without this trace flag and we found that it does not help.

    After upgrade to CTP3 SGAM blocking slows down temp table creation to 5 ... 40 sec

    0 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →

    Upvotes: 1

    <=-=Jan 30 2007 4:33PM=-=>

    Please provide more information.

    Why do you think it is due to SGAM blocking? SGAM contention in tempdb usually is due to multiple connections trying to access/update SGAM page. From the script you provide, I do not see this is the case (and 0 row is inserted into temp table, which does not go through SGAM at all).

    Thanks
    Stephen

    <=-=Jan 30 2007 10:01PM=-=>

    >Why do you think it is due to SGAM blocking?
    Because CSS told me so. Examples of contention resources:
    2:1:3
    2:4:3
    2:19:3

    The this was happening (it’s no longer happening now, we’re actively monitoring for issue return) it reproed for
    a) SELECT INTO
    b) CREATE #TABLE; INSERT 1 row (not create was slow, but inserting first, and only first, row)
    c) DECLARE @Table TABLE; INSERT 1 row (also slow on insert, not create)

    <=-=Jan 31 2007 5:59PM=-=>

  15. SQL 2005 deadlock vs SQL 2000 normal work

    This a continue of ID 252468
    To avoid "phantom read" i set isolation level to SERIALIZABLE in Query #3 and get deadlock. But under SQL 2000 SP4 no deadlock's found

    1) Why SQL 2005 deadlock in this example?
    2) How i can cancel this deadlock?

    P.S.Set "with (xlock, serializable)" in all 2.sql for insert, 3.sql for select, 4.sql for update not solve the problem

    0 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  16. MDX Properties Statement

    Hi,

    Microsoft recommended that we upgrade our server to SP2 (CTP). After doing so, I have found one problem. When we use the properties statement in a MDX query to restrict the resultset, it is ignored and all properties are returned.

    Is this a known issue with the latest SP2 CTP?

    0 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  17. Minor issue with dm_exec_text_query_plan

    There is a mismatch between the contents of the queryplan column of the dmexectextquery_plan function and that column's datatype. The column contains an xml plan but the column type is varchar(max). According to BOL, the column should contain the text plan. Either the text plan or xml plan is fine, but the type should match the contents (varchar(max) if it's the text plan and xml if it's the xml plan).

    It's not a big deal, but SSMS has separate output length settings and click-behavior for xml data vs. varchar data in grid output, and you have…

    0 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  18. Fresh SQL Server 2005 giving problem in accessing Access 97 file using Jet 4.0 driver

    Problem:Jet 4.0 Ole DB Provider does not work for fresh installation of SQL 2005 server

    Environmental steps:

           1.Installed XP Sp2 on a new machine

    2.Installed SQL 2005 Server with SP1.Tried SP2-CTP also.

    3.Trying to import data from an access 97 file

    Problem:The linked server gets created but when try to read data we get error in opening database.
    Attaching mdb file also

    This error doesn't come if machine is not fresh.


    0 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  19. Support for DROPing schemas form an existing XML Schema collection

    Currently there is no way to drop schemas from an XML Schema collection short of rebuilding the schema collection (and any columns/indices that reference it). This is true even there are no existing instances that "use" the schema components to be deleted.

    0 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →

    Upvotes: 2

    <=-=Mar 22 2007 6:48PM=-=>

    Dear Bassam. Thanks for your feedback. We will look into providing such functionality in a future release of SQL Server and appreciate your feedback.

    Please provide is with the rating for this feature request.

    Thanks and best regards
    Michael

    <=-=Dec 13 2007 2:46PM=-=>

    Reopening it to indicate that we are still requesting input on this item.

  20. No support for storing XML schema documents in a typed xml column

    While XML schema documents can be added to a XML schema collection, they can not however be added as rows in a XML typed column. This prevents us form storing schema documents as regular XML documents that they are.

    0 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →

    Upvotes: 2

    <=-=Mar 22 2007 6:42PM=-=>

    Dear Bassam… Thanks for your feedback. We are looking into enabling this in a future version of SQL Server. Currently, you will have to store such schemas in untyped XML data type columns.

    Also, we would appreciate, if you could provide a rating number for your request.

    Thanks and best regards
    Michael

  • Don't see your idea?

SQL Server

Categories

Feedback and Knowledge Base