SQL Server

Microsoft SQL Server powers your entire data estate by supporting structured and unstructured data sources. It builds on previous versions of SQL Server, which have been industry leading for four years in a row and a leader in TPC-E. It scales to petabytes of data and allows customers to process big data through PolyBase using T-SQL over any data. SQL Server has also been the least vulnerable database during the last seven years. SQL Server brings data insights with business intelligence capabilities that provide analytics at a fraction of the cost on any device along with advanced analytics with support for R and Python.


More details about SQL Server are available in the SQL Server documentation.
If you have a technical issue, please open a post on the developer forums through Microsoft Q&A or Stack Overflow

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. Report Builder - Corrupt SemanticModel on entity delete

    You can corrupt the SM by deleting a table from the DSV that is involved in role.

    1) Table A is related to table B which is related to table C
    2) In Entity /Table A select Role B � Expand inline and make some of Role B�s fields hidden
    3) In Entity / Table B select Role C - Expand inline and make some of Role C�s fields hidden
    4) Delete Table C from the DSV
    5) Build and you get errors (as you should)
    6) Delete Entity C from the model
    7) Build and error object required is…

    0 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  2. Reporting Services Wizard generated Analysis Services Reports empty

    If i create an Analysis Services Report using the Wizard the whole datasource/Query empties if i try to modify the report.

    0 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  3. Restore of transaction log fails using Management Studio

    If the transaction log contain multiple files some before and after when a full backup is taken then restoring using Management Studio fails. Transaction log can be restored using scripts but not use the GUI tool.

    0 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →

    Upvotes: 0

    <=-=Jun 20 2006 10:52PM=-=>

    This is probably the same bug as https://connect.microsoft.com/SQLServer/feedback/ViewFeedback.aspx?FeedbackID=124718

    <=-=Jul 27 2006 12:17AM=-=>

    Thanks for your feedback.

    It looks like recovering full back-up is done with RECOVERY option (which is default choice in Options tab) and then restoring transactional log is done, and that is why UI throws valid error message from Engine

    This should have been done by restoring full backup with NO RECOVERY option and then restore from UI the transactional logs to restore successfully.
    I tired it this way and it works fine.

    Thanks,
    Gops Dwarak

    <=-=Aug 8 2006 1:10PM=-=>

    Thank you again for submitting this report. We will look at fixing this issue in the next major release of SQL Server. In the meantime, there is a workaround. Here is the sequence of that we think is going on and what should happen.

    1. Take one or more backup of the…

  4. sp_help_job is executed evey time a job is viewed, can seriously delay display of job over a slow link

    Every time you view a job in SSMS it executes sphelpjob which returns the summary of all jobs to the client, irrespective of the job being selected. This results in the time taken to load the job details being delayed, espcially over a slow link with lots of jobs.

    With 1000 jobs (i.e. a report server) over a slow link 128kbs it could take ~1minute to display the job details page.

    I don't see why this call is needed. Its not called in with EM

    0 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →

    Upvotes: 10

    <=-=Jun 29 2006 3:47AM=-=>

    Thanks for reporting this issue and we are planning to address this in our next release.

    <=-=Jul 14 2006 4:22AM=-=>

    Surely this shouldn’t be closed until it is included in the next release. At which point it can be closed.

    <=-=Jul 17 2006 12:59AM=-=>

    Nice catch. This will be addressed in next service pack. Thanks

    <=-=Sep 18 2006 3:16PM=-=>

    I regret to inform you that we could not accomodate this bug in our next service pack. We will get another chance to address the issue in our next release.

    <=-=Nov 18 2007 3:30PM=-=>

    Sms,

    I have resolved this issue as a duplicate of bug 28715, which was reported earlier about delete but is the same issue.

    -Richard Waymire
    PM, SQL Server Agent

    <=-=Jun 17 2013 5:34AM=-=>

    Hi,
    Can you please tell me in which service pack does this has been addressed ?

    Thanks,
    Shivaji…

  5. GetSchemaDataSet browsing cubes returning 0 rows

    When querying an OLAP database for a set of cubes non are returned (only one cube is processed)

    0 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  6. Cannot assign a multi server job to a group of servers like in SQL 2000

    In SQL 2000 EM you can assign a multi server job to multiple servers by selecting a group. There is no option for doing this in SSMS.

    In SQL 2000 there is a button "Change..." that pops up a dialog where serevers can be selecetd individually or via a group

    0 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →

    Upvotes: 1

    <=-=Jul 3 2006 4:54AM=-=>

    Nice catch and thanks for reporting this.

    The current workaround of selecting individual servers should not block from using this scenario;however, this is little time consuming if there are various servers and some are grouped. We are planning to get this addressed in the next release.

    Once again thanks for reporting this bug.

    Thanks,
    Gops Dwarak

  7. SSMS error after renaming the server - need a solution that works flawlessly

    After renaming the server, SQL Server 2005 throws up an error dialog box when starting SSMS.

    0 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →

    Upvotes: 0

    <=-=Aug 7 2006 6:12PM=-=>

    Tested on clean machine (Windows 2003 + SP1), testing steps:

    1- Change the server name and restart.
    2- Opening SSMS (Opened).
    3- Trying to connect using:
    a- (local).
    b- (server new name).
    c- “.”
    And it connected through all of these

    <=-=Aug 10 2006 4:00PM=-=>

    Thank you for reporting the problem. Renaming a server after SQL Server is installed is a supported scenario. However, we were unable to reproduce it. Here’s what we tried:
    Tested on clean machine (Windows 2003 + SP1), testing steps:

    1- Change the server name and restart.
    2- Opening SSMS (Opened).
    3- Trying to connect using:
    a- (local).
    b- (server new name).
    c- “.”

    In each of these cases, Management Studio started up and was able to connect. I’m going to close this bug as not reproducible. If there is additional information that may help us reproduce the bug feel…

  8. Legacy Database Maintenance Plan doesn't show deleted databases included in plan

    If I use Sql Server Management Studio's Legacy Database Maintenance Plan to view legacy plans on a Sql Server 2000 database, I cannot see deleted databases that are part of the plan. I need to see the databases in order to delete them from the plan (since the database has been deleted after the plan was created). In order to remove the database from the plan, I had to use Enterprise Manager to edit the plan.

    0 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  9. Copy Datase wizards requires permissions on ALL databases, not just one being copied

    When running the Copy Database Wizard, if your login user doesn't have privileges on ALL the databases on the server, not just the one you need to copy, it can't even enumerate the database list for you to select your database. " The list doesn't show up for you to pick from.

    Copy Database is only usable if your user exists in ALL databases hosted on the server. So forget about 3rd party hosting altogether, and in an internal corporate environment, you need to have maximum privileges on ALL databases, or you're still out of luck. If you have control…

    0 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  10. Package Validation Error : The package designer deletes the code from script task.

    While Creating a script task in Control Flow, I am getting "Package Validation Error". Here is the complete message:

    Error at Validate File and Load Data: The task is configured to pre-compile the script, but binary code is not found. Please visit the IDE in Script Task Editor by clicking Design Script button to cause binary code to be generated.
    (Microsoft.DataTransformationServices.VsIntegration)

    As mentioned in the message, I opened the script IDE and added the code I need. When I close the VSA IDE, package designer displays the same error message.

    The worst part of whole story is that if I…

    1 vote
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  11. SSMSE: "Unable to view requested dialog"

    Choosing to view server autorizations SSMSE shows an error dialog.

    0 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →

    Upvotes: 2

    <=-=Jun 16 2006 7:44AM=-=>

    Hi PBSoft,
    Thank you for your feedback. The information you have provided in your feedback & repro steps is lacking credential information for the user running SSMSE as well the the credentials info related to the server. Also some of the feature/functionality available in regular SSMS may not be available via SSMSE. Please provide a more detail repro with related information to help us repro your issue.
    Thanks
    Ramesh Singh

    <=-=Jun 17 2006 11:34PM=-=>

    It’s the same bug as https://connect.microsoft.com/SQLServer/feedback/ViewFeedback.aspx?FeedbackID=126969

    <=-=Jun 18 2006 11:00PM=-=>

    For all aspects of the described problem I’m using SQL Server authentication, with the user ‘sa’.
    Regarding to operating system, Windows user is one of Administrators group.

    You said some features could not be available to SSMSE, ok: but don’t you think that I should see a warning message instead of the missing file dialog?

    Please, let me…

  12. Try catch fails inside a function

    When I create a function as follows:
    create function f (@x int) returns int as

    begin
    
    begin try
    set @x = 2
    end try
    begin catch
    set @x = 1
    end catch
    return @x
    end

    I get the following errors:
    Msg 443, Level 16, State 14, Procedure f, Line 4
    Invalid use of side-effecting or time-dependent operator in 'BEGIN TRY' within a function.
    Msg 443, Level 16, State 14, Procedure f, Line 6
    Invalid use of side-effecting or time-dependent operator in 'END TRY' within a function.
    Msg 443, Level 16, State 14, Procedure f, Line 7
    Invalid use of side-effecting…

    0 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →

    Upvotes: 43

    <=-=Jun 12 2006 10:43PM=-=>

    Books Online documents this behaviour, in topic “CREATE FUNCTION (Transact-SQL)”:
    “The following statements are valid in a function: […] Control-of-Flow statements except TRYCATCH statements. […]”

    However, this is a severe limitation that should be removed in a future release. You should post a suggestion in this regard and I will wholeheartedly vote for it.

    <=-=Jul 20 2006 2:23PM=-=>

    Hi,

    Thank you for bringing this issue to our attention. SQL Server 2005 does not support TRY CATCH blocks inside functions. We are looking at removing this restriction in a future release.

    Thank you,
    Tomer Verona (tomerv@microsoft.com)
    SQL Server Engine
    [MSFT]

    <=-=Nov 5 2009 10:53AM=-=>

    Hi,

    This is indeed a serious limitation and it breaks the whole logic of precise development. A UDF is supposed to do computation, and therefore needs TRY CATCH.

    Regards,
    Mustafa

    <=-=May…
  13. Cube browser doesn't show cube metadata

    I wanted to browse a cube so I opened an MDX query in SSMS. I didn't know at the time but the cube wasn't processed so i get the message "Error loading metadata: No cubes were found" in the cube browser portion of the query window. No problem with that - that's fine.

    After that I processed the cube. I can query it successfully but I can never display the metadata of it. It continually shows the same message. Kind of defeats the object of having it there.

    0 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →

    Upvotes: 1

    <=-=Oct 25 2007 10:00AM=-=>

    We are investigating a fix to ensure the cube metadata is updated when the cube gets processed, targeting SQL Server 2008 for the fix. We’ll post another update when the issue is addressed.

    Thank you for taking the time to report your findings. We hope to make a better product with this in mind.

    Sincerely,
    Todd Fiala

    <=-=Oct 25 2007 10:13AM=-=>

    cool. Thank you Todd. And thanks also for putting your name on the comment rather than just a faceless “Microsoft”. Too many people don’t bother to do that.

    <=-=May 12 2011 7:25AM=-=>

    hi Jamie,

    This is a follow up email for connect item 131262 you previously created. We are unable to reproduce this issue any longer and would like to close the issue. Can you please try recreating the issue with a newer version (using SSMS) and let us know if you…

  14. SSAS: Apparently it takes longer to process the cube than the database!!

    Small one this. I've just noticed that if you process a database then on the 'Process Progress' screen it can show longer to process the cube than the database itself - which simply doesn't make sense.

    I tried to attach a screenshot but the submit complains that it is an invalid file which is of course complete rubbish.

    0 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  15. foreign key relationship allows typing into insert and update specification textboxes

    foreign key relationship allows typing into insert and update specification textboxes. If you do an error is generated. The dropdowns shouldn't allow any editing.

    0 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  16. SqlWb.exe window focus ON and OFF for every few seconds!

    Hi,

    �Microsoft SQL Server 2005 Management Studio� window is getting window's focus ON and OFF for every second which is really annoying. Could you help me how to fix it?

    Regards,
    Venkata Ramana

    0 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →

    Upvotes: 1

    <=-=Jan 7 2008 8:31AM=-=>

    Hi There,

    We were unable to reproduce the problem. This could have been an issue with your video card or video card driver. If you have any additional information that could help us to trouble shoot the problem please provide it.

    Thanks,
    Dan
    Lead Program Manager
    SQL Server Manageability

    <=-=Jan 10 2008 10:24AM=-=>

    Hi There,

    We were unable to reproduce the problem. This could have been an issue with your video card or video card driver. If you have any additional information that could help us to trouble shoot the problem please provide it.

    Thanks,
    Dan
    Lead Program Manager
    SQL Server Manageability

  17. Redraw issue in Grid in SQL Management Studio

    When running a query or a view in Management studio, the results grid gets corrupt after a repaint. This only occurs in the results pane in a view, not in the Criteria or SQL pane. In a Query window, only the Status text in the first pane of the status bar gets corrupted. The gird and other panes of status bar are fine.

    0 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →

    Upvotes: 2

    <=-=Jun 7 2006 8:44AM=-=>

    Hi ecirpnaes,

    Thank you very much for taking the time to contact us. Could you please give us more details
    about how to reproduce this problem? It might also be very useful if you could attach a screen
    shot of the results pane when the problem occurs.

    Thanks,
    Oscar Naim
    SQL Server
    Program Manager

    <=-=Jun 7 2006 9:48AM=-=>

    Attachements have been uploaded. I had attached them previously, but apparantly they did not go through. There is no additional information to reproduce. Just create a view or query and when the screen repaint, the grid is doubled in the view. Any activity causing a repaint, (moving a window in front, requery) causes the grid to go back to normal, but it soon returns to “doubled”.

    Note that on a multi-monitor system, this only occurs on the primary monitor. Moving SQL to a secondary monitor will…

  18. SSIS Error when debuging script task

    I have a script task with a break point. I was able to successful debug this script for a few hours, then I began having problems. First, the debug editor would come up, but I would not have any control. I waited a minute or so then when back to VS and stop debugging. The debugger closed, but I would get the error "MVSA has lost link to .". I could ok that message and debug again with success. After an hour or so, I started getting another message. This was a Just-In-Time debugging window stating that there was an…

    0 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →

    Upvotes: 1

    <=-=Jan 24 2008 9:48AM=-=>

    Hi, we are processing this bug and want to get more information from you so as to proceed. Here are our questions: 1) did it happen again or just once? 2) What version of SQLBuild you had on your machine? Which SKU (standard, enterprise, evaluation…)? If you can collect call stack information and send to us, that will be even better. Thanks for using Microsoft product, and looking forward to hearing back from you.

  19. Buffer Manager Cannot Get A Temporary Filename. The Call To GetTempFileName Failed.

    Receive errors similar to the following:

    Error: 0x80070050 at Import File, DTS.Pipeline: The file exists.

    Error: 0xC0048019 at Import File, DTS.Pipeline: The buffer manager could not get a temporary file name. The call to GetTempFileName failed.

    Error: 0xC0048013 at Import File, DTS.Pipeline: The buffer manager could not create a temporary file on the path "C:\Documents and Settings\michaelsh\Local Settings\Temp". The path will not be considered for temporary storage again.

    Error: 0xC0047070 at Import File, DTS.Pipeline: The buffer manager cannot create a file to spool a long object on the directories named in the BLOBTempStoragePath property. Either an incorrect file name was…

    0 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →

    Upvotes: 0

    <=-=Apr 2 2007 6:11PM=-=>

    Dear Customer,

    We have looked into this problem. A possible workaround is: go to the Property page of the DataFlow component, in the Misc group try increase DefaultBufferSize (the maximum value is 104857600) and increase DefaultBufferMaxRows to a larger integer. This will allow smaller number of temporary files to be created, and reduce the chance the temporary folder gets exhausted.
    This method does not guarantee to work around the problem but we are working on our best to fix your problem in our future release! Thank you for using SQL Integration Service and we appreciate your future support!

  20. sp_reset_connection need to clear CONTEXT_INFO

    spresetconnection does not clear CONTEXT_INFO

    It is possible with connection pooling enabled to read the CONTEXT_INFO of a previous session. This is especially true when a web-server is making hundreds of connections of behalf of web-users.

    0 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →

    Upvotes: 4

    <=-=Aug 22 2006 12:44PM=-=>

    Saying “won’t fix” without saying why doesn’t help. This is clearly a security bug that needs to be fixed.

    <=-=Sep 26 2006 11:05AM=-=>

    Hi
    Thanks for the feedback. We’re considering addressing this in an upcoming Service Pack of SQL 2005 and future releases of SQL Server.

    - Christian Kleinerman

    <=-=Oct 13 2006 5:17PM=-=>

    Hi Jack!

    Thank you for filing bug 126925
    (http://connect.microsoft.com/SQLServer/feedback/ViewFeedback.aspx?Feedb
    ackID=126925).

    I actually couldn’t repro it, so I’m having several questions.

    1. What is exactly version number of your SQL Server?
    2. What client API of what version are you using to connect to it
    at the client?
    3. I need a clarification on your repro sequence (between /* Load
    the saved context info / and /But hope that the connection pooling gives you the same connection*/comments). Do you assume somewhere in the middle the connection is reset? Or you…

  • Don't see your idea?

SQL Server

Categories

Feedback and Knowledge Base