SQL Server

Microsoft SQL Server powers your entire data estate by supporting structured and unstructured data sources. It builds on previous versions of SQL Server, which have been industry leading for four years in a row and a leader in TPC-E. It scales to petabytes of data and allows customers to process big data through PolyBase using T-SQL over any data. SQL Server has also been the least vulnerable database during the last seven years. SQL Server brings data insights with business intelligence capabilities that provide analytics at a fraction of the cost on any device along with advanced analytics with support for R and Python.

More details about SQL Server are available in the SQL Server documentation.
If you have a technical issue, please open a post on the developer forums through Stack Overflow or MSDN.


  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. Offset and length were out of bounds for the array or count is greater than the number of elements from index to the end of the so

    I got the exception below when opening a table.
    I Closed the table, and try to re-open it, it opened normally.

    Table contains two constraint key, and about 35 column and 1489 data rows.


    System.ArgumentException: Offset and length were out of bounds for the array or count is greater than the number of elements from index to the end of the source collection.
    at System.Buffer.BlockCopy(Array src, Int32 srcOffset, Array dst, Int32 dstOffset, Int32 count)
    at Microsoft.VisualStudio.DataTools.UI.QueryResult.FileStreamReader.ReadOneT
    at Microsoft.VisualStudio.DataTools.UI.QueryResult.FileStreamReader.ReadInt32(Int64 i64Offset, Boolean bSkipValue, SpecialDataType& specialDataType, Int32& val)
    at Microsoft.VisualStudio.DataTools.UI.QueryResult.DiskStorageView.SequentialReadColumn(Int32 iCol, Boolean bSkipValue)
    at Microsoft.VisualStudio.DataTools.UI.QueryResult.DiskStorageView.GetCellDataFromFileInternal(Int64 i64Row, Int32 iCol, Boolean fGetRealData)
    at Microsoft.VisualStudio.DataTools.UI.QueryResult.DiskStorageView.GetCellData(Int64…

    0 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →

    Upvotes: 0

    <=-=Jul 12 2006 9:49AM=-=>

    Thank you for your bug report regarding Open Table. Are you able to consistently reproduce the problem?
    Thank you,
    Bill Ramos

    <=-=Jul 18 2006 2:18PM=-=>

    Hi FarSee,
    In looking into this problem, we have determined that the issue doesn’t warrant a fix for SP2. We are going to look at this in the next major release of SQL Server.
    Thank you,
    Bill Ramos

  2. SQL Server 2005 SP1 error: A transport-level error has occurred when receiving results from the server

    I got the folowing error on SQL Server 2005 SP1:

    Msg 109, Level 20, State 0, Line 0
    A transport-level error has occurred when receiving results from the
    server. (provider: Shared Memory Provider, error: 0).

    After this error SQL Server service crashes.

    My system info:
    --Microsoft SQL Server 2005 - 9.00.2047.00 (Intel X86)
    -- Apr 14 2006 01:12:25
    -- Copyright (c) 1988-2005 Microsoft Corporation
    -- Standard Edition on Windows NT 5.1 (Build 2600: Service Pack 2)

    Connection type: TCP/IP

    see "Steps to Reproduce" section and attached error log for more detail

    0 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →

    Upvotes: 2

    <=-=Aug 7 2006 2:50PM=-=>

    Thank you for reporting this issue. We have found the underlying problem and will fix this in SP2. We truly appreciate your taking the time to tell us about this issue, and help us make the SQLServer a better product.

    -erik

    <=-=Oct 31 2006 3:44PM=-=>

    I received this error while running DBMail and also running an RMO script to create Replication.
    DBMail was running msdb.dbo.sp_send_dbmail in SSMS (SQL 2005).
    Visual Studio 2005 was running a replication method:
    subscription.SynchronizationAgent.Synchronize();

    <=-=Oct 31 2006 3:46PM=-=>

    This is more info related to the previous comment:

    — Error when running DBMail

    Msg 109, Level 20, State 0, Line 0
    A transport-level error has occurred when receiving results from the server. (provider: Shared Memory Provider, error: 0 – The pipe has been ended.)

    — Error at the same time running RMO to setup replication. Command running: subscription.SynchronizationAgent.Synchronize();

    Microsoft.SqlServer.Replication.ComErrorException (0×80004005):…

  3. SQL Server Agent properties in Management Studio shows wrong server adresse

    When I, in my Management Studio, open properties for the SQL Server Agent it shows wrong title on the form. It looks like it replaces . with (Local), this makes the title looks strange when connected to a server with a IP adresse.

    In my case:
    143(Local)97(Local)3(Local)180

    The SQL Server agent is running on SQL Server 2000 but the Management Studio is 2005, so I guess this is the correct place.

    0 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  4. German errormessage / "No mapping between account names and security IDs was done"


    1. Bug:

    Win 2003 Advanced Server, english
    SQL 2005 Enterprise Edition, english
    SQL 2005 SP1, english

    Regional Settings: german

    The error: "Systemfehler: ." occurs, no more details

    After switching the regional settings to english, the error below occurs.


    1. Wish

    More detailed error message, the stated error message means: check you users in the rolesdefinition.

    0 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  5. SQL Management Studio Express errors on Vista

    When working with SSMS-E on Vista (build 5456.5), an error occurs when enumerating databases, tables, etc. The error happens once, and then if you refresh the node, it won't happen again.

    Note: this is on vista even though the OS for this report says WinXP -- Connect would not allow me to keep the selection as Other.

    0 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  6. can't save Profiler trace to file

    can't save Profiler trace to file , this option not available
    Logged as admin -> create new trace -> check save to file
    as soon as cursor moved from checkbox area it become unchecked

    0 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →

    Upvotes: 0

    <=-=Jul 3 2006 4:53PM=-=>

    Thanks for sending the wmv over. We reviewed it last week. We are still unable to reproduce the behavior in our labs. Could you try the following…

    1) Open Profiler
    2) Start new trace without saving to file
    3) After the trace has collected some events, stop the trace.
    4) Choose File → Save As → Trace File…

    If this works, you have a workaround. (You can also save to a file by setting up a trace through T-SQL)
    If this doesn’t work, I do not think the problem you are experiencing is due to SQL Server’s tools. Your machine most-likely has an improper configuration that could have been caused by failed installations or using beta software. Some of your system files may be the problem.

    Please let me know your findings at your earliest convenience.

    Paul A. Mestemaker II
    Program Manager…

  7. Unable to edit values by typing in cells when joining tables opened via Object Explorer

    When opening a table using Object Explorer and joining that tble to a second table using an Inner Join on the primary key of each table, I am unable to edit the data by typing new text (or numbers) in any of the cells displayed (in Sql Server Management Studio and similarly in Visual Studio 2005). In contrast, if I run the same query in Visual Studio 2003 on the same tables, I am able to edit the data in either table. If I only query one of the tables in SSMS (or in Visual Studio 2005) then I am…

    0 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →

    Upvotes: 12

    <=-=Jun 27 2006 10:11AM=-=>

    Hi Matt,
    Thank you for taking the time to describe the problem with the query designer and its inability to edit data in joined tables. Did this used to work for you in SQL 2000?
    Thank you,
    Bill Ramos

    <=-=Jun 27 2006 11:37AM=-=>

    I see this problem when querying tables in either a Sql Server 2000 DB or a Sql Server 2005 DB. Please see the “Expected Results” portion of my initial bug-report for more info.

    <=-=Jul 10 2006 8:22AM=-=>

    Hi Matt,
    I did some digging around and it turns out that the team that supplied SSMS with the component disabled editing of the results set when multiple tables are involved. Your best bet is to create a view and then edit the data for the view. SQL Server will then be responsible for the possible updates. We will investigate what it will take…

  8. Database Backup and Restore Events report in SSMS returns no data

    The Database Backup and Restore Events report in SSMS returns no data for a database even though it has been backed up/restored. This is on Build 2153 (Post SP1 hotfix rollup). I've attached screenshot of empty report and csv of one of the report queries captured from Profiler that shows that data is being returned to the report, it's just not being displayed

    0 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →

    Upvotes: 2

    <=-=Jun 30 2006 4:36PM=-=>

    What on earth does the Resolution “RESOURCE NOT LOCATED” mean?

    <=-=Jul 13 2006 9:06AM=-=> Hi Jasper,

    I am not sure what the resolution “RESOURCE NOT LOCATED” means, but I can confirm that this issue has been resolved and the fix will show up in SQL Server 2005 SP2 release.

    Thank you for submitting this defect.

    Regards,
    Maciek Sarnowicz

  9. DB-Owner cannot exec stored-proc that he himself created!

    I think that the following bug is backward-comatability issue with 2005 vs. 2000.

    The script below runs perfectly on SQL2000, but fails on SQL2005.
    Please note: I need to run it under an SQL-login, NOT a windows-login.
    I grant this SQL-user a db_creator server-role.

    Apart from that, I set my SQL-User to be ddladmin+dbwriter+dbreader on the 'model' db.
    (and of-course, remove the db_owner on 'model' - this is what makes the bug happen).
    The reason is I want this user to have those access-rights to any new DB that he does NOT own.
    For DBs that he does own, 'model'…

    0 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  10. SQL Server Management Studio: window close button doesn't work

    The close button on some child windows (the X widget on top-left window) sometimes doesn't work properly.
    The icon mouse, when moved on it surface, became as angular-resizer.

    0 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →

    Upvotes: 0

    <=-=Jun 23 2006 3:46PM=-=>

    Thank you for reporting the problems you are encountering trying to close a window in the sql server tools. I am sorry that you are having problems reproducing this behavior. I too am unable to cause this problem to occur.

    I am going to mark this issue to indicate that we don’t yet have a repro case. I encourage you to continue your efforts to isolate the conditions that lead to this problem. If you are able to do so, please return here and activate the issue, which will again bring it to my attention.

    Thank you,

    James Howey

    <=-=Sep 15 2006 4:36AM=-=>

    The bug appers sisthematically.

    <=-=Sep 15 2006 7:24AM=-=>

    We have been unable to reproduce this behavior in our labs. Regretably, we are unable to diagnose and fix a problem we cannot reproduce.
    If you should figure out what sequence of operations…

  11. Single Tran Insert into a remote SQL server becomes multipe inserts.

    I`m running a insert from a SQL 2005 server (SP1) to a SQL 2000 server (SP4 build 911). The insert enters 20 rows. However the insert is being broken down into 20 individual inserts which are causing triggers to fire 20 times where as we want them to fire once.

    If i run the same code from SQL 2000, the insert is only fired once.

    I have confirmed this by tracing and examining the execution plans.

    0 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →

    Upvotes: 0

    <=-=Jun 21 2006 5:02PM=-=>

    Hi,

    I have found an error in my testing and reproduced the behaviour with SQL 2000 to SQL 2000 so please close this case as i now need to research the behaviour further.

    Thanks

    Andrew

    <=-=Jul 18 2006 10:21AM=-=>

    I will try to find out the repro, but please please please include the create table commands – it helps us out a lot.

    Thanks,
    Conor Cunningham
    Microsoft

    <=-=Sep 27 2006 6:28PM=-=>

    Closing it. Thanks.

  12. Cannot reference objects by name in an XMLA Process command

    The XMLA Process command references objects by ID rather than name. I really don't think this is a good idea. ID is an immutable property so it doesn't make sense to use it to identify objects especially as we don't have much control over what value is in there..

    I've talked about this here: http://blogs.conchango.com/jamiethomson/archive/2006/06/20/4106.aspx

    I DO think this is a bug because I think this behaviour is a mistake.

    0 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →

    Upvotes: 15

    <=-=Aug 18 2006 4:40PM=-=>

    This is a good suggestion. We will consider it for the next release of SQL Server.

    <=-=Jul 26 2007 12:22PM=-=>

    According to an email that I have just received pertaining to this submission “Field Resolution changed from [Not Set] to [Won’t Fix]”

    Why is that? Why can’t it be fixed? How about an explanation? I do not believe that this can’t be fixed – it is an inherent problem in the current product.

    <=-=Jan 16 2008 10:03AM=-=>

    i ran in the exact same issue and i think it’s annoying. basically i have no idea of the ID’s of my partitions whereas i can enforce a naming convention in the partition name. in this way i can relatively easily process only the last partition. if i need to get the id of that partition, it’s not easy at all..

    <=-=Apr 8 2009 7:34AM=-=>

    amateurish isn’t…

  13. Report Builder - Corrupt SemanticModel on entity delete

    You can corrupt the SM by deleting a table from the DSV that is involved in role.

    1) Table A is related to table B which is related to table C
    2) In Entity /Table A select Role B � Expand inline and make some of Role B�s fields hidden
    3) In Entity / Table B select Role C - Expand inline and make some of Role C�s fields hidden
    4) Delete Table C from the DSV
    5) Build and you get errors (as you should)
    6) Delete Entity C from the model
    7) Build and error object required is…

    0 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  14. Reporting Services Wizard generated Analysis Services Reports empty

    If i create an Analysis Services Report using the Wizard the whole datasource/Query empties if i try to modify the report.

    0 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  15. Restore of transaction log fails using Management Studio

    If the transaction log contain multiple files some before and after when a full backup is taken then restoring using Management Studio fails. Transaction log can be restored using scripts but not use the GUI tool.

    0 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →

    Upvotes: 0

    <=-=Jun 20 2006 10:52PM=-=>

    This is probably the same bug as https://connect.microsoft.com/SQLServer/feedback/ViewFeedback.aspx?FeedbackID=124718

    <=-=Jul 27 2006 12:17AM=-=>

    Thanks for your feedback.

    It looks like recovering full back-up is done with RECOVERY option (which is default choice in Options tab) and then restoring transactional log is done, and that is why UI throws valid error message from Engine

    This should have been done by restoring full backup with NO RECOVERY option and then restore from UI the transactional logs to restore successfully.
    I tired it this way and it works fine.

    Thanks,
    Gops Dwarak

    <=-=Aug 8 2006 1:10PM=-=>

    Thank you again for submitting this report. We will look at fixing this issue in the next major release of SQL Server. In the meantime, there is a workaround. Here is the sequence of that we think is going on and what should happen.

    1. Take one or more backup of the…

  16. sp_help_job is executed evey time a job is viewed, can seriously delay display of job over a slow link

    Every time you view a job in SSMS it executes sphelpjob which returns the summary of all jobs to the client, irrespective of the job being selected. This results in the time taken to load the job details being delayed, espcially over a slow link with lots of jobs.

    With 1000 jobs (i.e. a report server) over a slow link 128kbs it could take ~1minute to display the job details page.

    I don't see why this call is needed. Its not called in with EM

    0 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →

    Upvotes: 10

    <=-=Jun 29 2006 3:47AM=-=>

    Thanks for reporting this issue and we are planning to address this in our next release.

    <=-=Jul 14 2006 4:22AM=-=>

    Surely this shouldn’t be closed until it is included in the next release. At which point it can be closed.

    <=-=Jul 17 2006 12:59AM=-=>

    Nice catch. This will be addressed in next service pack. Thanks

    <=-=Sep 18 2006 3:16PM=-=>

    I regret to inform you that we could not accomodate this bug in our next service pack. We will get another chance to address the issue in our next release.

    <=-=Nov 18 2007 3:30PM=-=>

    Sms,

    I have resolved this issue as a duplicate of bug 28715, which was reported earlier about delete but is the same issue.

    -Richard Waymire
    PM, SQL Server Agent

    <=-=Jun 17 2013 5:34AM=-=>

    Hi,
    Can you please tell me in which service pack does this has been addressed ?

    Thanks,
    Shivaji…

  17. GetSchemaDataSet browsing cubes returning 0 rows

    When querying an OLAP database for a set of cubes non are returned (only one cube is processed)

    0 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  18. Cannot assign a multi server job to a group of servers like in SQL 2000

    In SQL 2000 EM you can assign a multi server job to multiple servers by selecting a group. There is no option for doing this in SSMS.

    In SQL 2000 there is a button "Change..." that pops up a dialog where serevers can be selecetd individually or via a group

    0 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →

    Upvotes: 1

    <=-=Jul 3 2006 4:54AM=-=>

    Nice catch and thanks for reporting this.

    The current workaround of selecting individual servers should not block from using this scenario;however, this is little time consuming if there are various servers and some are grouped. We are planning to get this addressed in the next release.

    Once again thanks for reporting this bug.

    Thanks,
    Gops Dwarak

  19. SSMS error after renaming the server - need a solution that works flawlessly

    After renaming the server, SQL Server 2005 throws up an error dialog box when starting SSMS.

    0 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →

    Upvotes: 0

    <=-=Aug 7 2006 6:12PM=-=>

    Tested on clean machine (Windows 2003 + SP1), testing steps:

    1- Change the server name and restart.
    2- Opening SSMS (Opened).
    3- Trying to connect using:
    a- (local).
    b- (server new name).
    c- “.”
    And it connected through all of these

    <=-=Aug 10 2006 4:00PM=-=>

    Thank you for reporting the problem. Renaming a server after SQL Server is installed is a supported scenario. However, we were unable to reproduce it. Here’s what we tried:
    Tested on clean machine (Windows 2003 + SP1), testing steps:

    1- Change the server name and restart.
    2- Opening SSMS (Opened).
    3- Trying to connect using:
    a- (local).
    b- (server new name).
    c- “.”

    In each of these cases, Management Studio started up and was able to connect. I’m going to close this bug as not reproducible. If there is additional information that may help us reproduce the bug feel…

  20. Legacy Database Maintenance Plan doesn't show deleted databases included in plan

    If I use Sql Server Management Studio's Legacy Database Maintenance Plan to view legacy plans on a Sql Server 2000 database, I cannot see deleted databases that are part of the plan. I need to see the databases in order to delete them from the plan (since the database has been deleted after the plan was created). In order to remove the database from the plan, I had to use Enterprise Manager to edit the plan.

    0 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  • Don't see your idea?

SQL Server

Categories

Feedback and Knowledge Base