How can we improve Azure Cloud Shell?

Increase 10 minute inactive timeout

Currently deploying some complex ARM templates from powershell on my computer can take up to 30 minutes - Powershell is running inside New-AzureRmResourceGroupDeployment commandlet and then returns success/failure. 10 minutes inactivity timeout is too low for such scenarios.

BTW, Google Cloud shell has 1 hour limit https://cloud.google.com/shell/docs/features - The instance persists while your Cloud Shell session is active and terminates after an hour of inactivity.

5 votes
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    Signed in as (Sign out)

    We’ll send you updates on this idea

    Frantisek Dufka shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

    19 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      Signed in as (Sign out)
      Submitting...
      • John Dawson commented  ·   ·  Flag as inappropriate

        I have an ARM deployment that takes 28 minutes and I want screenshots afterwards. Twice now I've lost the screen and had to do over. I'd really appreciate a 1 hour timeout or even better (as I assume it consumes resources) make it configurable similar to font size as something like 10 mins, 30 mins, 60 mins.

      • Washim Nawaz commented  ·   ·  Flag as inappropriate

        Cloud shell does not work well, timeout occurs every two 3 mins while you are typing.
        Is there any solution to this annoying interruption ?

      • Anonymous commented  ·   ·  Flag as inappropriate

        I believe the timeout is much shorter than 20 minutes. I think it's closer to 2-3 minutes. It will even quit in the middle of a command. This is ridiculous for a development tool. I understand not wanting it to be misused for lengthy processes, but it's a rather short timeout (shorter than 20 minutes).

      • philip gahan commented  ·   ·  Flag as inappropriate

        also happening for me , even if I use a separate tab of shell.azure.com within the browser , 5 mins max and it times out

      • Fryderyk Supinski commented  ·   ·  Flag as inappropriate

        Why not make this a session idle timeout? Only increment the session timeout counter while waiting for user input, and don't increment the session time-out counter while waiting for an operation to complete.

      • Vidar Hagen commented  ·   ·  Flag as inappropriate

        I'm using Cloud shell for training session and would like it to be extended to 1 hour. Alternative there could be a setting with default 20min and max 1hour

      • Richard Cove commented  ·   ·  Flag as inappropriate

        The cloud shell is almost unusable due to the time out issues
        I get time outs even when I am typing or editing a file, I am pretty sure that the 20 minutes is not related to activity but the time since login, so a session has to be less than 20 minutes
        If i use shell.azure.com, i have to go through the ms login process each time i timeout

      • Tom Ptacek commented  ·   ·  Flag as inappropriate

        I agree with the others, 20 minute timeout is too short. Should be a settable parameter. It would be different if you could pop open an Azure PowerShell like a cmd window - and it came up quickly. The pain comes because it's a minute wait to start one up. I could see an hour being the max, people could live with that.

      • Dimi Goranov commented  ·   ·  Flag as inappropriate

        The timeout is 2-4 min on my end as well. If I switch to another browser tab for more than 3-4min I have to restart the shell. This is very annoying and makes the developers live difficult.

      • Joshua Niland commented  ·   ·  Flag as inappropriate

        I agree with others. The timeout is 2-4 mins at best!

        This unfortunately makes the use of the Azure Cloud Shell useless for lengthy tasks such as deployments or AZCopy etc.

      • Anonymous commented  ·   ·  Flag as inappropriate

        I'd doubt it is 20 minutes before a timeout - normally around 3 or 4 minutes of inactivity (while looking up technet articles, etc), then I come back to the shell and it's timed out already. If it was actually 20 minutes, then it's probably something I can live with, but the 3-4 minute timeout definitely needs to be increased.

      • Anonymous commented  ·   ·  Flag as inappropriate

        Even 20 minutes is not really long enough. I am trying to deploy application gateways which are notoriously slow.

      • JM commented  ·   ·  Flag as inappropriate

        This is not completed. Timeout still occurs for me at about 2-4 minutes - does not last for full 20 minutes (or even close).

      • Frantisek Dufka commented  ·   ·  Flag as inappropriate

        Not sure what is maximum timeout of New-AzureRmResourceGroupDeployment and whether it was bug or feature but when I tried some template for environment with 2 VMs, azure search, 2sql servers, redis and app insights it sometimes failed with a message about exceeding 30(?) minute timeout and I had to delete some partially initialized resources and re-run it again to continue and finish the rest. So I guess 30 minutes is a minimum but I'm not 100% the number was really 30 or more..

      Feedback and Knowledge Base