Do you have an idea or suggestion based on your experience with Azure Database for PostgreSQL?

URL encode PostgreSQL connection strings

The string I got initially was as follows:

postgres://user@postgre-resource-name:password@host:5432/database

Because @ sign appears twice, some tools like pg_dump were confused. The issue was solved by URL encoding the first @:

postgres://user%40postgre-resource-name:password@host:5432/database

3 votes
Sign in
(thinking…)
Sign in with: Microsoft
Signed in as (Sign out)

We’ll send you updates on this idea

Timur Kuzhagaliyev shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

Thanks for using Azure Database for PostgreSQL.

Where are you requesting that we display this url encoded version? You mention that you got the first string – was this from one of our documents? Do let me know so we can update it. Also, you can directly use the GitHub issues commenting system to request changes to Azure documentation on a document page.

Thanks,
Rachel on behalf of the Azure Database for PostgreSQL team

2 comments

Sign in
(thinking…)
Sign in with: Microsoft
Signed in as (Sign out)
Submitting...

Feedback and Knowledge Base