I suggest you ...

GiveSetting to increase the mod_security limit for following attributes : SecRequestBodyLimit 536870912 SecRequestBodyNoFilesLimit 536870912

we hosted application in Azure VM and configured WAF Application Gateway. But we are getting following error

Request body no files data length is larger than the configured limit (131072).. Deny with code (413)

For this we done so much googling and found the solution that we need to increase following parameters in the application gateway. If not possible then need configuration to by pass this limit checking so our application will not stuck because sometime application need to send request with this length.

Request to increase the mod_security limit for following attributes : SecRequestBodyLimit 536870912 SecRequestBodyNoFilesLimit 536870912

Many others are facing same issue and reported to Microsoft as well.

24 votes
Vote
Sign in
(thinking…)
Sign in with: Microsoft
Signed in as (Sign out)
You have left! (?) (thinking…)
Ankit Patel shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

1 comment

Sign in
(thinking…)
Sign in with: Microsoft
Signed in as (Sign out)
Submitting...
  • Anonymous commented  ·   ·  Flag as inappropriate

    I second this request. We are experiencing the same issue with WAF in front of a DotNetNuke website and a lot of the Admin functionality is blocked with a 413 ModSecirity error.

Feedback and Knowledge Base