Lab Services

Azure Lab Services is a service that enables you to easily set up and provide on-demand access to various systems and software for any workload: teaching a class, setting up a development or test environment, or running trials with customers. Manage and scale your group’s resources in lab environments, while minimizing waste and controlling cost. Choose between the two lab types, classroom lab or devtest lab, for an experience that is tailored to your scenario.

Visit the Azure Lab Services page to learn more.

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. Pending on createing artifacts

    Steps:
    Create CentOS based VM with artifacts YUM to install some package.

    Result:
    The VM is always under 'Applying artifacts' status

    Seems it is trying to install a windows artifact, but could not proceed.

    Status:
    Name Status
    windows-noop Installing
    linux-yum-package Pending

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Flag idea as inappropriate…  ·  Admin →
  2. Can't enable auto shutdown due to active blade.

    Can't enable auto shutdown due to active blade.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    closed  ·  1 comment  ·  Flag idea as inappropriate…  ·  Admin →
  3. issue with autoshutdown form

    form forces you to have both an email and webhook despite instruction message saying only one of the 2 is needed

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    closed  ·  1 comment  ·  Flag idea as inappropriate…  ·  Admin →
  4. Links in the auto-shutdown email do not work correctly

    It is helpful to make the links work correctly

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Flag idea as inappropriate…  ·  Admin →
  5. Auto shutdown is not working well for Mexico.

    I am in Mexico, but recently I can't deactivate the auto shutdown:
    IncorrectRequiredProperties Incorrect required property 'NotificationLocale'. Allowed values: zh-hant,cs,nl,en,fr,de,hu,it,ja,ko,pl,pt-br,pt-pt,ru,sv.
    Thanks,

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    4 comments  ·  Flag idea as inappropriate…  ·  Admin →
  6. Cannot press "Save" button in auto shutdown

    Cannot press "Save" button in auto shutdown

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Other  ·  Flag idea as inappropriate…  ·  Admin →
  7. Could not create new machine after clicking "Create" button

    Could not create new machine after clicking "Create" button, no response.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  DevTest Labs - Virtual Machines  ·  Flag idea as inappropriate…  ·  Admin →
  8. Artifacts not loading

    { "shellProps": { "sessionId": "a3fb046843284b2b861aabbf3824f309", "extName": "MicrosoftAzureDevTestLab", "contentName": "ArtifactsShoppingCartPart" }, "error": { "message": "Cannot read property 'id' of null", "code": null }}

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  DevTest Labs - Artifacts  ·  Flag idea as inappropriate…  ·  Admin →
  9. 1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Flag idea as inappropriate…  ·  Admin →
  10. 1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Flag idea as inappropriate…  ·  Admin →
  11. 1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Flag idea as inappropriate…  ·  Admin →
  12. 1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  DevTest Labs - Virtual Machines  ·  Flag idea as inappropriate…  ·  Admin →
  13. Custom Images Rest API can't be used!!!

    I want to get all of custom images from lab services by rest api.
    Lab Services URL: https://docs.microsoft.com/en-us/rest/api/dtl/
    The Custom Images are included in the Lab Services list, but it cannot be opened and show 404 that page not found.
    https://docs.microsoft.com/en-us/rest/api/dtl/customimages

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

  14. ET shows wrong time zone in summer time

    Eastern Time should be UTC -04:00, not -05:00 on September. It is -05:00 only on November – March. But in the selection of time zone it always shows “UTC -05:00 Eastern Time (US & Canada)”.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Flag idea as inappropriate…  ·  Admin →
  15. Set subnet policy using powershell

    We start deploying DevTest LAB for univerties.
    We have 1 project with 150 LABs so we are about to deploy all the LABs using Powershell but we are not able to configure the subnet policy using powershell :
    - Used for VM creation
    - Activate shared public IP address
    - Activate public IP address creation

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Flag idea as inappropriate…  ·  Admin →

    Thanks for the feedback. Here are some resources for your question.
    ARM template sample: https://github.com/Azure/azure-devtestlab/blob/master/Samples/301-dtl-create-lab-with-existing-vnet/azuredeploy.json

    Rest API for VNets: https://docs.microsoft.com/en-us/rest/api/dtl/virtualnetworks/update

    For classroom scenarios please consider using our managed service known as Azure Lab Services.
    Here is a link to learn more: https://azure.microsoft.com/en-us/services/lab-services/

  16. Please, fix autoshutdown

    Hi,

    I'm running a Centos 7.4 Linux VM on Azure.
    I set auto shutdown to run at 9:20 EST : it did nothing, not even sent
    me the email notification.
    I found no trace of errors or warning on the Activity Log neither
    May you, please, fix this functionality ? Thanks in advance,

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Flag idea as inappropriate…  ·  Admin →
  17. need to improve recalculating time

    I had been set the shutdown time at 10:00 PM so i have received the alert for same half an hour before. That time, it was working so i have gone to setting of auto shutdown and changed the time to 11:00 PM even though my system has went down instead recalculating the new time.

    One more thing, there should also notification for down on ARM portal if auto shut down has scheduled.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    closed  ·  1 comment  ·  Flag idea as inappropriate…  ·  Admin →
  18. Show added artifacts

    When you have added Artifacts to a Resource (VM) you are unable to see what artifacts are assigned.

    Now it's possible to add the same resource multiple times, and you are unable to remove an artifact if you accidently selected the wrong one.

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    closed  ·  1 comment  ·  Flag idea as inappropriate…  ·  Admin →
  19. 1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    closed  ·  1 comment  ·  Flag idea as inappropriate…  ·  Admin →
  20. I cannot create vm from ASG-WS-Pilot-Lab resource group. it keeps failing on allocation ip address. Can anyone help me out of the issue?

    I cannot create vm from ASG-WS-Pilot-Lab resource group. it keeps failing on allocation ip address. Can anyone help me out of the issue?

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    closed  ·  1 comment  ·  Flag idea as inappropriate…  ·  Admin →
  • Don't see your idea?

Feedback and Knowledge Base