DevTest Labs

Azure DevTest Lab is a service that helps developers and testers to quickly create environments in Azure while minimizing waste and controlling cost. You can test latest version of your application by quickly provisioning Windows and Linux environments using reusable templates and artifacts. Easily integrate your deployment pipeline with DevTest Lab to provision on demand environments. Scale up your load testing by provisioning multiple test agents. Also, create pre-provisioned environments for training and demo.

Visit the Azure DevTest Labs page to learn more about DevTest Labs and how to get started.

How can we improve Microsoft Azure DevTest Labs?

(thinking…)

Enter your idea and we'll search to see if someone has already suggested it.

If a similar idea already exists, you can support and comment on it.

If it doesn't exist, you can post your idea so others can support it.

Enter your idea and we'll search to see if someone has already suggested it.

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. 1 vote
    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      Signed in as (Sign out)

      We’ll send you updates on this idea

      0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
    • Fix artifact upload for nested ARM templates with sub folders

      I'm building an ARM Template using nested templates and artifacts in sub folders. The ARM template is stored in a repository which is linked with a DTL. When creating an environment from the template, DTL doesn't upload all the subfolders to the storage account which breaks deployment and is a different behavior from that in Deploy-AzureResourceGroup.ps1.

      The proposed fix is simple: copy all subfolders from the repo just like the script Deploy-AzureResourceGroup.ps1 from the Resource Group project template in VS.

      1 vote
      Sign in
      Check!
      (thinking…)
      Reset
      or sign in with
      • facebook
      • google
        Password icon
        Signed in as (Sign out)

        We’ll send you updates on this idea

        0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
      • auto-shutdown notification doesn't send an email for one of my VMs

        I received correctly auto shutdown notification email for other VMs. However, one of my VMs doesn't send an email even though the configuration is same as the others. Auto shutdown itself is working fine, so this VM is automatically shutdown without notification.
        Since this subscription has no support request, this is not a request to fix my VM. I just report it as a bug which might happen commonly.

        1 vote
        Sign in
        Check!
        (thinking…)
        Reset
        or sign in with
        • facebook
        • google
          Password icon
          Signed in as (Sign out)

          We’ll send you updates on this idea

          0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
        • Fix Shutdown Notifications when Posting to Microsoft Teams

          The hyperlink to postpone does not work properly when posted to a Microsoft Team webhook

          1 vote
          Sign in
          Check!
          (thinking…)
          Reset
          or sign in with
          • facebook
          • google
            Password icon
            Signed in as (Sign out)

            We’ll send you updates on this idea

            0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
          • Don't see your idea?

          Feedback and Knowledge Base