Logic Apps

Logic Apps allow developers to design workflows that articulate intent via a trigger and series of steps, each invoking an App Service API app whilst securely taking care of authentication and best practices like durable execution.
If you have any feedback or ideas on Azure Logic Apps we’d love to hear it.

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. MQ connector in logic apps just stopped working

    I had a (working) logic app which was sending data to an MQ queue. Now it has ceased to work because it's removed the datagram I was sending, which was the output of a previous action (parse JSON). When I go back into the logic app designer and try to add the message, it allows me to select it, but the designer does not allow me to save the changes.

    1 vote
    Vote
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    0 comments  ·  Connectors  ·  Flag idea as inappropriate…  ·  Admin →
  2. Add flow triggers for flow!

    I would like to see triggers based on flow conditions, and primarily for failed flows

    4 votes
    Vote
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    0 comments  ·  Flag idea as inappropriate…  ·  Admin →
  3. SharePoint Online - When an existing item is modified - MMS Column Failure - Bad Gateway

    Steps to reproduce:

    1) Add 'When an existing item is modified' trigger to a new Logic App or Flow.

    2) Target list has MMS column where internal name is different to display name - a display name with spaces ('Company Name'), and an internal name without ('CompanyName').

    Result: On run, Bad Gateway: status 502, message "Unknown Error", source "<URL>/_api/SP.APIHubConnector.GetUpdatedListItems".

    Does not appear to happen with other types of field (e.g. text, lookup). Does not seem to depend upon term set title.

    Workaround: create columns where the internal name and display name are the same.

    Why this is bad: it encourages…

    4 votes
    Vote
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  4. Pin buttons to start

    Add functionality to pin buttons to the start menu to run flows without opening the app first.

    1 vote
    Vote
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    0 comments  ·  Flag idea as inappropriate…  ·  Admin →
  5. Deployed Logic App Designer View Different than Actual Deployed Version

    I found a situation where, if I open the Logic App in the portal designer, I am seeing a very old version of it (which it seemingly would allow me to edit). However, this is not actually the real runtime version. If I go into the history and look at the latest, it reflects what I actually deployed. Additionally, when I execute the workflow and look at the workflow execution details, it is also correct. I am speculating that the potential cause of this is that 1) I first deployed the app from Visual Studio; 2) I edited the app,…

    1 vote
    Vote
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    0 comments  ·  Management  ·  Flag idea as inappropriate…  ·  Admin →
  6. Fix trigger for Azure blob storage

    The new trigger for azure blob connector does not show in the UI this optional parameter:
    -)startTime
    -)timeZone

    They can be used in the json but the UI does not provide the input (optional)

    Without those parameters you can set the trigger frequency but you cannot set when to start counting periods.

    3 votes
    Vote
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  7. The format of the SQL Adapter connectionstring

    We are connecting from Logic Apps to an OnPrem SQL Server using the SQL Adapter via the On Premise Data Gateway.

    On May 17 @ 02:00 (CET) our integrations started failing because you changed the format of the connectionstring from hostname:port to hostname, port.

    You changed it a few month ago also, but from , to :

    Why do you keep changing this back and forth?

    1 vote
    Vote
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  8. Getting relative URL of file content instead of Base64 data from LogicApp Salesforce Connector

    I want to implement the scenario using LogicApp that whenever the new Attachment will be uploaded to Salesforce then this attachment should get copied to SharePoint document library.

    I am using Salesforce trigger(When_a_record_is_created) in LogicApp, Salesforce Object type is Attachments, so whenever the new attachments is uploaded in salesforce then LogicApp will be triggered.

    I am using the SharePoint action(Create File in SharePoint). The parameters of the create file action are File Name, File Content, Folder Path.
    I have selected name and body property of the trigger in File Name and File Content parameters of Create File action respectively.

    When…

    3 votes
    Vote
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  9. From where can I get Primary access key and secondary access key of my logic app?

    From where can I get Primary access key and secondary access key of my logic app?

    3 votes
    Vote
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  10. Losing "statecode" in Dynamics CRM inputs when toggling between Designer and Code View

    When I toggle between the Designer and the Code View, I lose the "statecode" input element, and its value, for a Dynamics CRM Insert and Update ('patch' method).

    When using Dynamics CRM entities, I need to set whether the record is 'active' or 'inactive'. Therefore, I need to correctly set both "statuscode" and "statecode". When "statecode" disappears, then subsequent LogicApp runs which change from active to inactive which encounter runtime errors due to failed validation as the new combination is invalid (the reason why both codes need to be set correctly)

    3 votes
    Vote
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  11. OneDrive Delete file action is not working

    API not found error when its used

    1 vote
    Vote
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    0 comments  ·  Connectors  ·  Flag idea as inappropriate…  ·  Admin →
  12. Read a csv file and bulk load into Azure SQL table

    I would like to read in a file from blob and add a row to a table in Azure SQL server. It would be nice to have a bulk import like bcp but also be able to add new rows as the file grows.

    126 votes
    Vote
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    3 comments  ·  Connectors  ·  Flag idea as inappropriate…  ·  Admin →
  13. SQL Stored Procedure parameter mapping order

    When executing a stored procedure with several optional parameters on our on-premise database via a Data Gateway connector, the parameter mappings seem to be based on the listed order in the json definition only and not by the actual parameter name.
    In our case two nvarchar-parameters to be cast into date and integer, respectively, needed to switch place in the stored procedure definition in order to make it work. A more rigorous and fail-safe binding seems to be needed.

    1 vote
    Vote
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  14. Filename using MultiByte Char is garbled

    When Japanese is used as the file name, the file name is garbled and linked. Confirm the phenomenon with BOX connector or FileSystem connector.

    ファイル名に日本語を利用している場合、ファイル名が文字化けして連携される。BOX コネクタや、FileSystem コネクタで現象を確認。

    1 vote
    Vote
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  15. EDIFACT-EANCOM Subset decode error

    I tryed to decode a EDIFACT-EANCOM message.
    I did load the correct schema (this is working on premise) in the agreement.
    If I check the log I can see some of the value were found:

    "UNA_Segment": "UNA:+.? '",
    "UNB": {
    "UNB_Segment": "UNB+UNOC:3+4399902256179:14+4399901763173:14+161113:0936+31704163'################",
    "UNB2.1": "4399902256179",
    "UNB2.2": "14",
    "UNB3.1": "4399901763173",
    "UNB3.2": "14"
    },
    "UNH": {
    "UNH1": "1",
    "UNH2.1": "SLSRPT",
    "UNH2.2": "D",
    "UNH2.3": "01B",
    "UNH2.4": "UN",
    "UNH2.5": "EAN006"
    },
    "decimalPointIndicator": 44,
    "repetitionSeparator": 42,
    "escapeCharacter": 63,
    "technicalAckExpected": false,
    "functionalAckExpected": false,

    But I got this error:

    "Error encountered during parsing. The Edifact transaction set with id '' contained in interchange (without group) with id '31704163',…

    1 vote
    Vote
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    1 comment  ·  Enterprise Integration  ·  Flag idea as inappropriate…  ·  Admin →
  16. EDIFACT

    I just tested both EDIFACT Encode (by Identities and by agreement) i tryed to create an output file into drop box, for the output content I tryed different Tag:
    Transformed XML: show me the EDIFACT Message as XML, this is correct.
    Payload: I think this should be the correct EDI File but what I get is not an EDIFACT file, no idea where these values are coming from. (see attachment)

    Was this tested? As an EDIFACT expert I'm happy to help if needed

    1 vote
    Vote
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    1 comment  ·  Enterprise Integration  ·  Flag idea as inappropriate…  ·  Admin →
  17. Support for API Connections in custom API Apps

    Provide support for (re)using API Connections in custom API Apps to perform authentication with external services.

    15 votes
    Vote
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    1 comment  ·  Flag idea as inappropriate…  ·  Admin →
  18. Retry doesn't work with SFTP connector

    There is something called RetryPolicy available for logic app actions to retry the actions in case of intermittent connectivity issues. I tried this option with an SFTP connector but was not able to find a scenario where the retry would happen.

    My intention was to make sure the SFTP file upload action would retry at 1 min interval for 3 times. For this I renamed the sftp folder temporarily, but the workflow run itself failed and in the very first attempt.

    We need a solution such that for any kind of error, we should be able to retry.

    3 votes
    Vote
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    2 comments  ·  Connectors  ·  Flag idea as inappropriate…  ·  Admin →
  19. O365 Outlook Connector - designer removes attachments array

    I have a very simple logic app, consisting of two actions:
    1. Request (trigger)
    2. O365 outlook connector - send email

    The first lines of my logic app:
    "$schema": "https://schema.management.azure.com/providers/Microsoft.Logic/schemas/2016-06-01/workflowdefinition.json#",
    "actions": {
    "Send_an_email": {
    "inputs": {
    "body": {
    "Attachments": "@triggerBody()['attachments']",
    "Body": "@{triggerBody()['mailBody']}",
    "Cc": "@{triggerBody()['ccToAddress']}",

    Now when I save this app in code view it works perfectly fine. As soon as I make the mistake of opening the app in the designer it removes the 'attachments' line.

    1 vote
    Vote
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    0 comments  ·  Connectors  ·  Flag idea as inappropriate…  ·  Admin →
  20. I've never done party configuration for EDI files in BizTalk 2010, so I need some simple info.

    I'm dropping xml files to BizTalk and creating HIPAA 835 files out. I get how you set up the basic party info to put all the appropriate information in the ISA and GS fields, but how do I set up a third party (i.e. US, THEM1 and THEM2)? I'm only dropping to a single send port, so how can I let BT know which party to use for which file?

    1 vote
    Vote
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    1 comment  ·  Enterprise Integration  ·  Flag idea as inappropriate…  ·  Admin →
  • Don't see your idea?

Logic Apps

Categories

Feedback and Knowledge Base