How can we improve Azure Backup?

Add MABS support to VMWare ESXI 6.7

I'm trying to backup VMs from an ESXI 6.7 host, however, the MABS solution does not support ESXI 6.7 yet.

84 votes
Vote
Sign in
(thinking…)
Sign in with: Microsoft
Signed in as (Sign out)
You have left! (?) (thinking…)
Edson de Paula shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

9 comments

Sign in
(thinking…)
Sign in with: Microsoft
Signed in as (Sign out)
Submitting...
  • David Farr commented  ·   ·  Flag as inappropriate

    @Graham; Acknowledged & thanks for sharing.
    I have since resolved my scenario by re-enabling TLS 1.0 on the Vcenter and retaining the IgnoreCertificateValidation as True as our environment is secure enough to not require the certs. Your method is certainly more secure as a best practice.

  • Graham Stewart commented  ·   ·  Flag as inappropriate

    Hey David,

    I posted it after testing it in my environment and i was over the moon that I could protect my vSphere 6.7 environment. It had been a while coming!

    All i did to get it operational was

    1. Install the Product
    2. Import the vSphere Root Cert in to the Computer Account/Trusted Root Authorities
    3. Added reg keys
    4. reboot

    and it just started working. Couldn't get the DNS name to work but IP address was fine. Additionally i didn't seem to get the username format user@domain working. Seemed to need DOMAIN\user format.

    Hope that helps

  • David Farr commented  ·   ·  Flag as inappropriate

    Has Microsoft's workaround solution (noted by Graham below) actually worked for anyone ?
    These registry hacks (including the typo) are also mentioned at; https://docs.microsoft.com/en-us/azure/backup/backup-azure-backup-server-vmware#vmware-vsphere-67 although I've had no joy with them (yes, I did reboot). I've enabled TLS 1.2 via registry entries alone [.....\SCHANNEL\Protocols\TLS 1.2]. Additional efforts included re-importing the VMware certificates.
    All done; since upgrading my VMware to 6.7 I still cannot connect MABS to Vcenter. Connections via the server IE browser work correctly. Am I perhaps missing something ?

  • Graham Stewart commented  ·   ·  Flag as inappropriate

    VMWare vSphere 6.7
    To backup vSphere 6.7 do the following:
    Enable TLS 1.2 on DPM Server
    Note
    VMWare 6.7 onwards had enabled TLS as communication protocol.
    Set the registry keys as follows:
    Windows Registry Editor Version 5.00
    [HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft.NETFramework\v2.0.50727] "SystemDefaultTlsVersions"=dword:00000001 "SchUseStrongCrypto"=dword:00000001
    [HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft.NETFramework\v4.0.30319] "SystemDefaultTlsVersions"=dword:00000001 "SchUseStrongCrypto"=dword:00000001
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft.NETFramework\v2.0.50727] "SystemDefaultTlsVersions"=dword:00000001 "SchUseStrongCrypto"=dword:00000001
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft.NETFramework\v4.0.30319] "SystemDefaultTlsVersions"=dword:00000001 s"SchUseStrongCrypto"=dword:00000001

  • Cranky SE commented  ·   ·  Flag as inappropriate

    While I understand that software is always a moving target, vCenter 6.7 has been out for almost a year. This is taking far longer than it should--which frankly looks like a design issue to me. I can't in good faith recommend this to my customers when your support lags so far behind.

  • John C. commented  ·   ·  Flag as inappropriate

    I was performing an evaluation of DPM to replace our existing on-prem backup solution and ran across the same issue. It has been months now since we upgraded to 6.7 and still no support. I cannot recommend this product if it will take almost half a year to support VMware releases. We cannot afford to be without backups for a day let alone 6 months.

  • Ben commented  ·   ·  Flag as inappropriate

    I'm facing the same issue, upgraded vcenter to v6.7 to find our backup solution now doesn't work. gahhh....

Feedback and Knowledge Base