Update: Microsoft will be moving away from UserVoice sites on a product-by-product basis throughout the 2021 calendar year. We will leverage 1st party solutions for customer feedback. Learn more here.

Automation

Azure Automation allows you to automate the creation, monitoring, deployment, and maintenance of resources in your Azure environment using a highly-available workflow execution engine. Orchestrate time-consuming, error-prone, and frequently repeated tasks against Azure and third party systems to decrease time to value for your cloud operations.

Visit the Automation page to learn more about Automation and how to get started.

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. Add possibility to end a test job when it hangs.

    Sometimes when running code in a PS runbook something seems to hang. I'm getting the following error although the job probably finished long time ago:
    "BadRequest: Test job is already running."
    I would like to have the opportunity to clear any running test jobs to bypass this bug.

    107 votes
    Vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
    You have left! (?) (thinking…)
    6 comments  ·  Bug  ·  Flag idea as inappropriate…  ·  Admin →
  2. Change behavior when sandbox runs out of memory (1MB max to one stream limit)

    There is currently a maximum limit of 1MB when outputting values to the any stream (Serialized size per object in pipeline).
    I understand why this limit is there, but I don't think the current behavior is the right way to go.

    Current behavior is that the runbook restarts, and runs 3 times until it is stopped with the following error:

    Suspended
    The job action 'Activate' cannot be run, because the process stopped unexpectedly. The job action was attempted 3 times.

    If we run it on look at the eventlog on a hybrid worker (this error also happens in Azure workers),…

    74 votes
    Vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
    You have left! (?) (thinking…)
    3 comments  ·  Bug  ·  Flag idea as inappropriate…  ·  Admin →
    under review  ·  Beth Cooper responded

    Thanks for posting this feedback! I’m checking with our team to see if there is anything that we can do about this in the short term. We’ll definitely take this into consideration in our longer term plans.

  3. "Copy" as in Copy/Past works intermittently from Edit screen

    When trying to copy paste data, the copy works intermittently at best. I have not been able to reliably replicate a scenario where this works. I can literally select some text, copy it, paste it to notepad (or something else), then go back to copy something else and it fails to copy still retaining what I last had in the clipboard.

    12 votes
    Vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
    You have left! (?) (thinking…)
    2 comments  ·  Bug  ·  Flag idea as inappropriate…  ·  Admin →
    under review  ·  Beth Cooper responded

    Thanks for reporting this! What browser are you using? Does refreshing the portal help with the issue?

  4. previously working SSH scripts now says "cmdlet not found"

    This may be temporary since I've noticed some changes in the preview portal, but my previously (about 12 hours ago) working SSH scripts are now not recognizing Invoke-AutomationSshCommand:

    Failed
    The term 'Invoke-AutomationSshCommand' is not recognized as the name of a cmdlet, function, script file, or operable program. Check the spelling of the name, or if a path was included, verify that the path is correct and try again.

    9 votes
    Vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
    You have left! (?) (thinking…)
    2 comments  ·  Bug  ·  Flag idea as inappropriate…  ·  Admin →
    under review  ·  Beth Cooper responded

    Hi Linus,

    I think this was answered on a few other channels, but wanted to post an update here just in case. We have removed this default module from the service, and do not have a planned ETA on when we will add this back.

    I’ll treat this as a vote to add a Microsoft Linux supported module, to help us prioritize when we can get the module back into the service.

    Thanks,
    Beth

  5. Start-AzureRmAutomationDscCompilationJob incorrect error message when configurationname is incorrect

    When calling Start-AzureRmAutomationDscCompilationJob if the configurationname parameter is not a published config, the error message reports that the AutomationAccount is not found.

    The correct error should state that the ConfigurationName is not found.

    6 votes
    Vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
    You have left! (?) (thinking…)
    1 comment  ·  Bug  ·  Flag idea as inappropriate…  ·  Admin →
  6. Text selection bug in runbook editor for Edge browser

    When editing a runbook and trying to select a single line of text, I cannot select all of the text and end of the selection jumps around. You can reproduce easily if the line is a comment and start with a # symbol.

    I am running Windows 10 Enterprise build 14257.rs1_release.160131-1800/

    5 votes
    Vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
    You have left! (?) (thinking…)
    2 comments  ·  Bug  ·  Flag idea as inappropriate…  ·  Admin →
  7. Edge

    When using MS Edge with AA and the preview portalm the browser reloads the entire portal when you try to start a runbook with parameters.
    Repro:
    - selected a runbook
    - click on start
    - when the parameters balde opens try to modify a parameter

    3 votes
    Vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
    You have left! (?) (thinking…)
    2 comments  ·  Bug  ·  Flag idea as inappropriate…  ·  Admin →
    under review  ·  Beth Cooper responded

    Are you still having this issue? I am unable to reproduce this issue in the edge browser now and can successfully start both test and published runbooks.

    If you are still experiencing the same problem, can you please provide more detail.

  8. Give feedback when saving fails

    When savinig fails of a runbook there is no good feedback on how to fix it. And the runbook that can't be saved can't be copied to save changes

    3 votes
    Vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
    You have left! (?) (thinking…)
    0 comments  ·  Bug  ·  Flag idea as inappropriate…  ·  Admin →
    under review  ·  Beth Cooper responded

    Thank you for reporting this. Our team is actually aware of the issue and is currently investigating. I don’t think we need anything from you at this point to investigate, but will let you know if that changes.

    As a temporary workaround, when you see this error, you can typically fix it by closing out your current browsing session and starting a new one.

  9. RSA two factor authentication causes a login error in the ISE-AddOn

    When using the ISE Add-In and logging in with two factor RSA authentication the login page errors out.

    Line: 280, Char: 1, Error: Unable to set property 'onkeypress' to undefined null reference. Code: 0

    1 vote
    Vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
    You have left! (?) (thinking…)
    1 comment  ·  Bug  ·  Flag idea as inappropriate…  ·  Admin →
  10. Test Pane should pre-populate previous Start Values (like the ISE Add-On)

    This feels like a bug in the Portal UI, if for no other reason than the API must support it, and the Azure Automation Add-On for PowerShell ISE supports it as well.

    If I create a new runbook in the Portal, add a parameter, then start it with the Test Pane.. if I then switch over the Add-On, and for that same new runbook click the 'Test Draft In Azure' then 'Start New Job' button, the parameter values I entered in the UI are pulled into the text entry.

    I created this as a new request because the existing request…

    1 vote
    Vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
    You have left! (?) (thinking…)
    under review  ·  0 comments  ·  Bug  ·  Flag idea as inappropriate…  ·  Admin →
  11. Bug in associate shcedule to a runbook through cmdlet Register-AzureRmAutomationScheduledRunbook

    You can define inconsistent types between runbook parameter type and the type of the parameter associated with a schedule. For example, if you have a runbook RB0, it has a parameter P0 of type Boolean.
    You can actually use Register-AzureRmAutomationScheduledRunbook cmdlet to associate a schedule with parameter P0 of a string type.

    1 vote
    Vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)
    You have left! (?) (thinking…)
    0 comments  ·  Bug  ·  Flag idea as inappropriate…  ·  Admin →
  • Don't see your idea?

Feedback and Knowledge Base