How can we improve Azure Automation service?

LCM DSC Proxy Awareness

Currently the LCM is not proxy aware, in our case there's no direct route to Azure resulting in the LCM to fail when trying to register. It would be great if the Local Configuration Manager had this capability.

61 votes
Vote
Sign in
(thinking…)
Sign in with: Microsoft
Signed in as (Sign out)
You have left! (?) (thinking…)
Michael Waterman shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

Thank you everyone for the continued feedback on this! This has been delivered in Server 2019 and was already a capability in the Linux agent. It is also possible to workaround the issue in previous versions of Windows using the DSC resource to manage proxy settings in NetworkingDSC, though it is a workaround since configuring proxy settings for the system account could impact other services.

For more information see:
https://docs.microsoft.com/en-us/azure/automation/automation-dsc-overview#proxy-support

5 comments

Sign in
(thinking…)
Sign in with: Microsoft
Signed in as (Sign out)
Submitting...
  • Melvin Veenbrink commented  ·   ·  Flag as inappropriate

    bitsadmin /util /setieproxy localsystem MANUAL_PROXY <proxyaddress> ";*.<domain>" will work to onboard a server to Azure Automation with the LCM.

  • Vivek commented  ·   ·  Flag as inappropriate

    Would be great to have this feature as we are rolling out a massive fleet of servers & services on Azure and this issue is causing grief.

  • Julien commented  ·   ·  Flag as inappropriate

    Using proxy settings from the user Could be a possible fix with the -Credentials Parameter

    Workaround:
    Open IExplorer with PSexec.exe and configure the proxy

Feedback and Knowledge Base