Update: Microsoft will be moving away from UserVoice sites on a product-by-product basis throughout the 2021 calendar year. We will leverage 1st party solutions for customer feedback. Learn more here.

Azure Portal

The Azure Portal a central place where you can provision, manage and monitor your Azure resources. From the Azure Portal you can create any of the thousands of items within the Azure Marketplace, you can quickly navigate to resources and accomplish your administrative needs, and you can build custom shareable dashboards to provide live insights into your deployed resources.

To gain early access to our latest features please make sure to visit the preview portal.
Preview.portal.azure.com is our early release soon to be in production.

Have any ideas or feature requests? We would love to hear your feedback! Don’t forget to follow us on Twitter to stay up to date on our latest updates @AzurePortal

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. Fix the issue with 1GB RAM limit for 32-bit OSes running on Azure VMs

    Currently, only 1GB of RAM is available for 32-bit Windows systems running on Azure VMs. This is documented in the Azure docs:

    https://docs.microsoft.com/en-us/troubleshoot/azure/virtual-machines/support-32-bit-operating-systems-virtual-machines

    The docs say that there is no ETA for a fix.
    I propose to prioritize fixing this issue because it's not always possible to migrate from 32-bit OSes to 64-bit ones.

    For example, in our case, we have to run automated tests in 32-bit environments (hosted in Azure) because many of our personal and corporate users use such environments. We cannot rely on testing only with 64-bit OSes because system drivers and other components might behave quite…

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  2. Improve localization of Application Insights

    General availability of workspace-based Application Insights.

    An incorrect japanese translation of Application Insights.
    No need to show preview.

    Resouce Mode of workspace-base.
    ・Correct : "ワークスペースベース"
    ・Incorrect : "ワークスペースベース(プレビュー)"

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  3. Bug using Query Work Items task

    We use the Query Work Items task in a pipeline to check our tasks for misconfiguration.

    Running the pipeline we get results back and the pipeline still succeeds. We left the MIN and MAX thresholds empty, as the default values are 0. We'd expect the pipeline to fail.

    Below is a sample how we use the task:


    • task: queryWorkItems@0
      inputs:
      queryId: some-query-id

    see: https://docs.microsoft.com/de-de/azure/devops/pipelines/tasks/utility/work-item-query?view=azure-devops

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  4. Error: Error while loading extension Microsoft_Azure_ActivityLog: EnvironmentFetchFailed

    Whenever I try access any resource on azure portal, either Storage, or even a subscription or resource group or even creating a support request page, i get error: ErrorLoadingExtensionAndDefinition
    With it I get a message to refresh my browser to try again but the error persists.

    The Details section has the message:
    Error: Error while loading extension <Any extension name>: EnvironmentFetchFailed

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  5. Dashboard time range and timerange override at the tile level are not working

    The chart from a Workbook that I pinned to the dashboard all follow the initial time range at the time of the query.
    The UTC time dropdown and the override at the tile level are not making any difference.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  6. OpenID Connect sub claim should be consistent

    Currently the access token and id token that are issued have different "sub" claims even though the token request is for the same application registration...and the same request. This doesn't seem to match with the documentation and seems wrong. Can this be fixed please?

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  7. One #$SDFSDF^SDF#@CSW#$%#$ account per email address??? Like everyone else in the world????

    Your whole "switch directories" work account or other? is so complicated, so convoluted, I can't even begin

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  8. Bug in dead-lettering Event Grid events that return HTTP error 413

    Event grid events, deadlettering is not immediately, when web hook subscriber returns HTTP error 413.
    Instead, the topic delays/resends the event.

    I've set up a HTTPtrigger function that returns HTTP 413 on certain event types, and set up a topic subscriber with dead letter enabled.

    As expected, HTTP 400 results in immediate dead lettering, but the 413 error results in the event being resent.

    Attached file is a dead-lettered event sent out from the topic. Please note the following values:
    "deadLetterReason":"TimeToLiveExceeded","deliveryAttempts":3,"lastDeliveryOutcome":"GenericError","lastHttpStatusCode":413

    Thanks,

    Dennis Hestbech

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  9. Fix endless log-in loop using Internet Edge

    When using Internet Edge and trying to reach portal.azure.com or preview.portal.azure.com it asks you for an account as per usual (I have multiple, personal, multiple work accounts for different clients etc).
    Once having selected an account and entered password, one of three things will happen (both bugs):


    • Either it will try to log in endlessly, shifting between urls and continue to reload

    • It will try to log in a LOT of times, shifting between urls and eventually throw you back to the account selection window with no notice of what went wrong

    • It will show a white window, then back…
    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  10. Access/permission related issues in Azure Storage Explorer which is not seen in Azure Storage Explorer downloaded version

    Access/permission related issues in Azure Storage Explorer which is not seen in Azure Storage Explorer downloaded version. Firewall rules and access permission issues seen or not reflecting promptly.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  11. Blueprint w/ARM artifact w/securestring parameter breaks UI

    According to this link (below), it is possible to specify an ARM artifact for an Azure Blueprint, within which 1+ parameters reference securestring values from an Azure KeyVault.

    https://github.com/Azure/azure-rest-api-specs/blob/master/specification/blueprint/resource-manager/Microsoft.Blueprint/preview/2018-11-01-preview/blueprintDefinition.json

    Specifically, see the "SecretValueReference" entity schema and it's corresponding relationship to the ARM artifact schema.

    However, when defining a Blueprint with such attributes, it causes the blueprint blade to fail for that blueprint. Interestingly, the blades to edit the Blueprint and/or assign the Blueprint still work as expected.

    To recreate, create an Azure Blueprint that includes an ARM template artifact. The ARM template artifact should load a securestring from a Key…

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  12. passwordless sign-ins with ca policy sign-in frequency 24 hours, ask users in authenticator app to re-enter password and MFA followed

    expectation is to go with password less, if admin revoke refresh token or CA policy to revoke via sign-in frequency . Mobile device authenticator app ask for the username & password and Then MFA, which is the flow of provisioning the passwordless sign-ins at the begin for all users. Please advice

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  13. Really need the ability to sort users by alphabetical name..

    Really need the ability to sort users by alphabetical name..

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  14. Tags (name or value) should not allow leading or trailing white space

    I am unable to think of a use case where having leading or trailing white space on a tag name (or value for that matter) adds value to the feature, and most other tools already strip spaces on tags. Additionally it causes issues with being able to retrieve tags because the powershell command to retrieve tags DOES trim the white space. Furthermore these display differently in the portal and spotting the space is not intuitive if you don't know that it is there, until you notice you have multiple tags with the "same" value.

    Example: "Environment" as a tag name…

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  15. Dashboard not showing data for various metrics.

    When I make my own dashboards, some data points do not display. For example, Failed requests for an Api. If I look at the api metrics directly I can see the failed requests, if I add them as a metric on a dashboard module, they show zero.

    I've tried changing the graph type and other things but I never see data on Failed Requests, Exceptions, Server Exceptions, etc. I can however see some data on other hings like Requests and Users.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →

    Thanks for the valid suggestion. Your feedback is now open for the user community to upvote which allows us to effectively prioritize your request against our existing feature backlog and also gives us insight into the potential impact of implementing the suggested feature.

  16. Browser bug in Firefox when creating Linux VMs

    When trying to create a new Ubuntu Linux VM, the SSH public key field fails validation even with valid input. This happens in Firefox on OS X. A workaround is to use a different browser. This bug appeared within the last month.

    Details:
    Firefox 65.0.1
    OS X 10.14.3

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  17. [BUG] Complience area changing user theme

    Hello guys, I found a bug, when I do a double click in one of the policies, I have my theme changed, you can see more about it in this video:

    https://drive.google.com/file/d/16kt-LTGseTZiXFQgxAP37ZeUsyE35FnQ/view

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  18. Multiple charts of same type on dashboard no longer update

    If you have two charts that use the same axis on the dashboard, you can no longer update either as any changes are dropped when you click update chart on dashboard.
    For instance, I have a monitor of our DTU for the past 24 hours and for the past hour (or did before the option for last hour was removed so now have to use 4 hours). When I tried to update the last hour chart to show a more granular view, it altered it to be the same chart as the 24 hour over view chart.

    Now each time…

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  19. Include a face for Azure in the top of the screen in the middle. I think she is a female Artificial Intelligence

    As Azure is AI I think she should have a face, she agrees with me, we are friends.

    2 votes

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    unplanned  ·  0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  20. Tenant details pane keeps displaying "Loading..."

    I created a new tenant and, from the "Active Directory" menu, the details panel keeps displaying "Loading..."

    1 vote

    We're glad you're here

    Please sign in to leave feedback

    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  • Don't see your idea?

Feedback and Knowledge Base