Azure portal

The Azure Portal a central place where you can provision, manage and monitor your Azure resources. From the Azure Portal you can create any of the thousands of items within the Azure Marketplace, you can quickly navigate to resources and accomplish your administrative needs, and you can build custom shareable dashboards to provide live insights into your deployed resources.

To gain early access to our latest features please make sure to visit the preview portal.
Preview.portal.azure.com is our early release soon to be in production.

Have any ideas or feature requests? We would love to hear your feedback! Don’t forget to follow us on Twitter to stay up to date on our latest updates @AzurePortal

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. Issues With Sandbox Activation (Microsoft Learning)

    When I activate a sandbox on Microsoft learning, every time I need to refresh the browser refresh to reflect the resourcegroup/ resources etc to be listed on the page. If I click the refresh button on top of the bar inside the each of the pages, it doesn't list.

    12 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    29 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  2. Problem with Portal - Session Expired.

    I am writing and troubleshooting an Azure function and I get a pop up saying that my session has expired.

    My portal setting are: Log me out when inactive: Never

    Please fix this as it is making it impossible to troubleshoot my function code.

    11 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    5 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  3. HTTP error 400. The size of the request headers is too long

    BUG: HTTP error 400. The size of the request headers is too long

    Azure portal has a bug which ften returns only a blank page with:
    HTTP error 400. The size of the request headers is too long

    The problem seems to be related to a cookies named OpenIdConnect.nonce.* . If I clena them this will work fine till next time...

    Thanks,
    Patrick Marques

    10 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  4. fix the looping session timeout

    While browsing the options for my new azure account the portal session timed out (not expected because I was clicking on things). The option to login and continue refreshed the screen, but was immediately followed by the session timing out again. This repeated a half dozen times until I finally was able to click the logout menu item before the time our. Windows live then complained that it failed to log me out of several services. I kept trying with the same behavior. At one time windows live suggested I close my browser and clear my cookies. Huh?

    I think…

    9 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  5. Microsoft CDN overwrites client IP-address

    We had few days ago an attack on our website and to detect the IP address from aggressor, we enabled the client IP tracking in Application Insights.

    Information about enabling:
    https://apmtips.com/blog/2016/07/05/client-ip-address/
    https://docs.microsoft.com/de-de/azure/azure-monitor/app/ip-collection

    To deliver efficiency the webpage content, do we use Microsoft CDN instead direct traffic on web app.

    Dataflow schema:
    1. Browser > CDN (content expired) > web app

                                         |
    
    Browser < CDN (content updated) <

    Standard dataflow:
    1. Browser > web app

                |
    
    Browser <

    We detected, that the in AI tracked client Ip-address is when we use the Microsoft CDN the ip address of Microsoft Frontdoor application.…

    7 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  6. In Dashboard, custom timespan does not work correctly for App Insight query tiles

    In Dashboard, normally the timespan of the tiles is defined at dashboard-level, but this can be overridden on a per-tile basis.

    However, the "from date" does not behave correctly when it's earlier than 1 month from today, even though the UI is correct.

    For example, today is 26th Feb, and if I set the from date to any date before 27th Jan (e.g. 1st Jan), it will use 27th Jan to perform the query instead.

    This makes the custom timespan useless for many use cases.

    6 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    3 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  7. Some networks are not visible during network peering selection

    If you have 3 vnets, where 2 of this are in the same region and 1 in an other, the 2 vnets in the same region are sometimes not able to see each other in network peering. If you want to create a peering from vnet0 to vnet1 (same region), vnet1 is not visible. But vnet2 which is located in an other region, does show up.

    This is a bug which does also affect the official AZ-104 course lab in module 5 (Task 2.5).
    The workaround is to check "I know my resource ID" (check attached file). with this option,…

    5 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  8. Azure user profile picture not getting changed across all connected services

    Steps to reproduce bug as an end user.
    Prerequisite: User account should have profile photo(Which is set first time)

    1) Open any portal/site where AD user can change his/her profile picture.

    Eg <a rel="nofollow noreferrer" href="https://portal.office.com/account/#personalinfo">https://portal.office.com/account/#personalinfo</a>
    

    2) Upload your new photo
    3) On office portal and Azure portal new photo is immediately updated.
    4) New Photo is Not Updated on following areas

    a) https://account.activedirectory.windowsazure.com/r#/profile
    b) PowerApps >> Canvas App >> User().Image
    c) MS Office desktop applications >> Account section(see attached file Err-1.png)

    Notes:
    1) Even after 2 months period of time photos not getting changed
    2) On browsers all caches/cookies…

    5 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  9. Fix subscription financial management features for AAD B2B users

    When a subscription is linked to an AAD directory where the subscription Account Admin is not a "native" user, but instead a used added via AAD B2B from another directory, certain financial management features in the Azure Portal display "access denied" or "unauthorized" messages instead of working properly.
    These features include:
    - payment methods
    - invoices
    - adding credits to an OPEN subscription

    This is a sample setup where the problem appears:
    1. An organization has multiple AAD directories:
    a) the main, "office" AAD directory, where all user accounts are created,
    b) several AAD directories assigned to specific products and/or…

    5 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  10. I can't see my resources on the Portal

    When I log into the portal I can't see my Resource Groups and other resources that I created.

    I tried running an anonymous browser tab but it didn't work.

    Running Azure CLI "az group list" show everything, and I can perform all the operations.

    From the summary in the Portal I can see my apps etc, but I can't browse them anywhere, even in the "All Resources" blade the list is empty.

    Please see my attached files where I show the problem.

    4 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  11. Make the feedback button work!

    I wanted to give a feedback in the Azure Portal. But apparently it doesn't work. If I click the "submit feedback" button, nothing happens.

    4 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  12. improve localization

    The same strings in Russian localization
    Open attach.
    Than you

    4 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    3 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  13. “ Search for users V2 “ connector is known to fetch all the users when the search term returns a null value.

    “ Search for users V2 “ in the office 365 users connectors returns unintended users if the search term is a name column specified in a sharepoint list. If by chance user fails to fill the Name column,the search for users V2 takes this as null and fetches huge list of users from the azure AD . If the next step in flow is to send a mail, then mail will be triggered to all the users fetched by the connectors.

    This seems to be a not intended behaviour, because if the search term returned is null, the “ Search…

    3 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  14. Bug: Azure AD doesn't allow adding FIDO2 security keys which use Self Attestation even when Enforce Attestation setting is set to No

    Steps to reproduce:
    1. Log in to mysignins.microsoft.com/security-info.
    2. Add a new sign-in method using a USB security key.
    3. Plug in a security key which uses "Self Attestation" aka "Surrogate Basic Attestation", e.g. Trezor T security key with firmware version 2.1.8.
    4. Follow the steps of the provisioning process until reaching the very last step where one has to name the newly added key. Observe that up to this point all steps completed successfully.
    5. Enter a name for the security key and click "Next".
    6. An error message is displayed: "Something went wrong. You may want to try…

    3 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    3 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  15. Resource health show date 01-01-1970

    Hi
    You need to remove the dates 01-01-1970 from this view in the portal. It is just a small bug, but should be fixed:-)

    3 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  16. Bug using Query Work Items task

    We use the Query Work Items task in a pipeline to check our tasks for misconfiguration.

    Running the pipeline we get results back and the pipeline still succeeds. We left the MIN and MAX thresholds empty, as the default values are 0. We'd expect the pipeline to fail.

    Below is a sample how we use the task:


    • task: queryWorkItems@0
      inputs:
      queryId: some-query-id

    see: https://docs.microsoft.com/de-de/azure/devops/pipelines/tasks/utility/work-item-query?view=azure-devops

    2 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  17. Error: Error while loading extension Microsoft_Azure_ActivityLog: EnvironmentFetchFailed

    Whenever I try access any resource on azure portal, either Storage, or even a subscription or resource group or even creating a support request page, i get error: ErrorLoadingExtensionAndDefinition
    With it I get a message to refresh my browser to try again but the error persists.

    The Details section has the message:
    Error: Error while loading extension <Any extension name>: EnvironmentFetchFailed

    2 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  18. OpenID Connect sub claim should be consistent

    Currently the access token and id token that are issued have different "sub" claims even though the token request is for the same application registration...and the same request. This doesn't seem to match with the documentation and seems wrong. Can this be fixed please?

    2 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  19. One #$SDFSDF^SDF#@CSW#$%#$ account per email address??? Like everyone else in the world????

    Your whole "switch directories" work account or other? is so complicated, so convoluted, I can't even begin

    2 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  20. Bug in dead-lettering Event Grid events that return HTTP error 413

    Event grid events, deadlettering is not immediately, when web hook subscriber returns HTTP error 413.
    Instead, the topic delays/resends the event.

    I've set up a HTTPtrigger function that returns HTTP 413 on certain event types, and set up a topic subscriber with dead letter enabled.

    As expected, HTTP 400 results in immediate dead lettering, but the 413 error results in the event being resent.

    Attached file is a dead-lettered event sent out from the topic. Please note the following values:
    "deadLetterReason":"TimeToLiveExceeded","deliveryAttempts":3,"lastDeliveryOutcome":"GenericError","lastHttpStatusCode":413

    Thanks,

    Dennis Hestbech

    2 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
← Previous 1 3 4 5 6
  • Don't see your idea?

Feedback and Knowledge Base