How can the Azure portal be improved?

The portal is really SLOW. Make it faster.

The title says it all.

632 votes
Sign in
(thinking…)
Sign in with: Microsoft
Signed in as (Sign out)

We’ll send you updates on this idea

André Melancia [MCT] shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

If you haven’t tried the portal in a while please give it a try.

Performance has been a key area of feedback and one where we have been focusing much of our efforts. We’ve been improving performance across all areas, specifically focusing on portal startup, performance of resource blades, and core portal experiences (like All resources). Measurements were done based on real usage (using telemetry) across all users and geographies. We tracked median and 95 percentile for each focus area.

As a result, you will enjoy of a faster experience with the portal. A few numbers:

• We improved portal startup +50%
• On average we improved resource blade (Web App, VM, and SQL) load +300%

Feel free to open new ideas for specific areas where we can continue to improve performance.

309 comments

Sign in
(thinking…)
Sign in with: Microsoft
Signed in as (Sign out)
Submitting...
An error occurred while saving the comment
  • Frederic Gos commented  ·   ·  Flag as inappropriate

    I've started using azure seriously for a real project the past few days, and to be honest I'm already completely fed up with how slow and full of bugs azure is. Will switch to something else next week if things don't improve.

    Are you serious about the fact that creating a tiny alpine linux VM should take 20 min? That's way more than what would be acceptable.

    Highly disapointed.

  • Anonymous commented  ·   ·  Flag as inappropriate

    2019, blade/Microsoft_Azure_Billing/ModernBillingMenuBlade/Overview has been loading for over ten minutes, kept retrying every 5, eventually it just started working in "decent" response time - that is 2009ish ~3 seconds.
    Microsoft wishes you a happy yeah 1999, with apologies for the lag.

  • Anonymous commented  ·   ·  Flag as inappropriate

    I can't believe how SLOW azure is in comparison to AWS. Creating (and deleting) TINY compute resources is 10 times slower than AWS.

  • Adrian commented  ·   ·  Flag as inappropriate

    Currently its just annoying how slow the portal is and what is even more insane is how long deployments take now. :(

  • Anonymous commented  ·   ·  Flag as inappropriate

    The portal is terribly slow. Currently have to use for university. Takes up to 60 seconds to load a page such as the classroom id page. Would never use my own money for this service. Google cloud and AWS have a much better experience.

  • Anonymous commented  ·   ·  Flag as inappropriate

    FWIW I think it's worse now. There are still lots of things that take 5-10 minutes (or more) to update, like changing backend pool config on an app gateway. That means testing a change can take half a work day! The new blades are horrific with horizontal scrolling it makes the portal basically unusable.

  • Anonymous commented  ·   ·  Flag as inappropriate

    Seems to have slowed down a lot lately. I've been using Azure for about 18 months and it started fine. A real shame and needs to be better for the money paid.

  • Alexander Poddubitsky commented  ·   ·  Flag as inappropriate

    You're literary pushing me and my team towards GCP & AWS. Azure functions UI is TERRIBLY SLOW STILL IN 2019. After a couple of Ctrl + F5 and taboo words it may become faster. But that's not how a good web app works, right?

  • Mark commented  ·   ·  Flag as inappropriate

    Function Apps are a promising tech, but the portal is too slow (not to mention function start up times) to make them usable. It can take five minutes for log entries to appear on the monitor for example, and even my tiny one function test app takes many minutes to restart once updated from GitHub. Until the portal is snappy, I can't recommend this to my clients for production use.

  • Pradeep commented  ·   ·  Flag as inappropriate

    Portal --> Function App --> Monitor takes my whole life to load. Please fix this guys.

  • Andrew Twigg commented  ·   ·  Flag as inappropriate

    Just clicking on things like settings can take a minute or so to respond. You just see a blade loading. This is painful.

  • Zach commented  ·   ·  Flag as inappropriate

    Still painfully slow, why not intelligently queue updates. Its sad that it take literally hours from components to update for non-prod items. It is utterly ridiculous an update takes hours at times for updates within the portal, but to redeploy would only take 30 mins. Fix this ****....

← Previous 1 3 4 5 15 16

Feedback and Knowledge Base