Azure portal

The Azure Portal a central place where you can provision, manage and monitor your Azure resources. From the Azure Portal you can create any of the thousands of items within the Azure Marketplace, you can quickly navigate to resources and accomplish your administrative needs, and you can build custom shareable dashboards to provide live insights into your deployed resources.

To gain early access to our latest features please make sure to visit the preview portal.
Preview.portal.azure.com is our early release soon to be in production.

Have any ideas or feature requests? We would love to hear your feedback! Don’t forget to follow us on Twitter to stay up to date on our latest updates @AzurePortal

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. Error: Error while loading extension Microsoft_Azure_ActivityLog: EnvironmentFetchFailed

    Whenever I try access any resource on azure portal, either Storage, or even a subscription or resource group or even creating a support request page, i get error: ErrorLoadingExtensionAndDefinition
    With it I get a message to refresh my browser to try again but the error persists.

    The Details section has the message:
    Error: Error while loading extension <Any extension name>: EnvironmentFetchFailed

    1 vote
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  2. Microsoft_Azure_Billing extension failed to load

    Whenever I try access any resource on azure portal, either Storage, or even a subscription or resource group or even creating a support request page, i get error: ErrorLoadingExtensionAndDefinition
    With it I get a message to refresh my browser to try again but the error persists. I have tried with both IE 11 and Old Edge browser with the same results.

    The Details section has the message:
    Error: Error while loading extension <Any extension name>: EnvironmentFetchFailed

    1 vote
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  3. Azure Portal Bait and Switch

    The selected resource unexpectedly changes when switching to the overview blade. Here are the steps I follow when the problem occurs:


    1. From the portal home page search for and select a resource type, such as virtual networks

    2. Select a virtual network from the list of all virtual networks in our tenant

    3. Select the peering's blade to view the peering's for the selected virtual network

    4. Click on another virtual network to view the peering's for it

    5. Click the overview blade to view the overview (and enable the delete option)

    On step 5, you would expect to see the overview for the…

    1 vote
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  4. When deleting VMSS instances Azure is deleting Healthy instances and keeping Unhealthy ones

    I had an instance where we scaled down the number of VM instances in a VMSS from 5 to 2. It so happened that 2 of the 5 instances had not come up properly and were not in an Healthy state. We were not aware of this.

    When we scaled down from 5 to 2 Azure deleted the 3 Healthy instances and kept the 2 Unhealthy ones.

    This resulted in our whole system going down. This should be addressed as a bug in Azure.

    1 vote
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  5. i cannot believe a company that is worth a trillion dollars released the azure portal as production app

    i cannot believe a company that is worth a trillion dollars released the portal as production app.

    i have used aws for years w/no issues. though i'd give azure a try.

    i started vms and signed up for subscription. everything was working fine, except when i got first bill. i clicked on the bill to pay it, logged in and it told me I wasn't authorized to do this.

    i tried this several times, with cookie clearing and incognito. same result. i then submitted a support request, including how to recreate including the urls and detailed error messages. several days…

    1 vote
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  6. Dashboard time range and timerange override at the tile level are not working

    The chart from a Workbook that I pinned to the dashboard all follow the initial time range at the time of the query.
    The UTC time dropdown and the override at the tile level are not making any difference.

    1 vote
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  7. “ Search for users V2 “ connector is known to fetch all the users when the search term returns a null value.

    “ Search for users V2 “ in the office 365 users connectors returns unintended users if the search term is a name column specified in a sharepoint list. If by chance user fails to fill the Name column,the search for users V2 takes this as null and fetches huge list of users from the azure AD . If the next step in flow is to send a mail, then mail will be triggered to all the users fetched by the connectors.

    This seems to be a not intended behaviour, because if the search term returned is null, the “ Search…

    2 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  8. 테넌트 삭제시 애플리케이션 구독과는 상관없이 삭제 할 수 있어야 합니다.

    테넌트를 생성하여 테스트 후 삭제하려고 했더니 구독중인 애플리케이션이 있다고 삭제가 되지 않습니다. 이는 버그와 같은 것으로 해석이 가능한게 애초에 삭제할 수 없으면 생성이 되지 않아야 합니다.

    1 vote
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  9. Some networks are not visible during network peering selection

    If you have 3 vnets, where 2 of this are in the same region and 1 in an other, the 2 vnets in the same region are sometimes not able to see each other in network peering. If you want to create a peering from vnet0 to vnet1 (same region), vnet1 is not visible. But vnet2 which is located in an other region, does show up.

    This is a bug which does also affect the official AZ-104 course lab in module 5 (Task 2.5).
    The workaround is to check "I know my resource ID" (check attached file). with this option,…

    5 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  10. Can't open resource overview page with IE11

    I can't open resource overview page with IE11. But Edge, Chrome or Firefox work well.
    When I tried to open resource overview page with IE11, something went wrong like attachment.
    The message in Japanese shows that the object doesn't support "find" property or method.

    1 vote
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  11. Dynamic column header issue -ODATA Source connection

    Hi,

    I am trying to fetch the data using ODATA to Azure Blob storage, In source the Column headers are changing every week with that the data is not copying with new header, Can we use dynamic schema mapping ?
    I really appreciate your help.

    1 vote
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  12. Firewall Policy resource stacked on Azure Portal after deletion

    I opened a support ticket (120061524005598) because I was not able to delete an Azure Firewall Policy.

    The product team deleted the Firewall Policy on the backend, however the Firewall Policy still appears on the Azure portal under the Firewall Policy blade.

    The support engineer asked me to report this as a bug.

    1 vote
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  13. Please fix broken UI elements on iPadOS/Safari

    Portal dropbown UI elements cannot be opened on ipad. Tapping on a dropbown in Safari on iPadOS flashes the contents of the dropdown but it immediately closes itself.

    Additionally, certain text fields within blades are broken. Eg: when setting an authorization callback URI on an AAD application, the cursor is always forced to the right-most end of the string in the text box. If I click in the middle of the string and type any key, my cursor jumps all the way to the right.

    1 vote
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  14. Clean up the dashboard of deleted items. There is no point to continue to show them after they are removed.

    I'm recording this as a bug - deleted resources continue to be shown on the dashboard and I have no ability to remove them.

    1 vote
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  15. I can't see my resources on the Portal

    When I log into the portal I can't see my Resource Groups and other resources that I created.

    I tried running an anonymous browser tab but it didn't work.

    Running Azure CLI "az group list" show everything, and I can perform all the operations.

    From the summary in the Portal I can see my apps etc, but I can't browse them anywhere, even in the "All Resources" blade the list is empty.

    Please see my attached files where I show the problem.

    4 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  16. In browser hold and drag (select) accidentally reveals previous page

    In portal:
    1. Search for "Policy"
    2. Start creating a new Policy definition
    3. Press mouse button in some empty space or inside Category text box
    4. Without releasing mouse button drag selection to the left, and keep dragging, like you normally do to select some text.

    Observe:
    You'll see that previous content/page starts to appear on the left. In my case list of all defined policies.

    If you drag far enough, you'll see an entire previous content.

    1 vote
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  17. Random Profile Picture Azure Generates not professional.

    The Random Profile Picture Azure generates when a users does not use a photo has some issues,

    we have users in Asian Countries that get like 1 English Alphabet then 1 native Language combined, which looks weird and unprofessional.

    Our Naming convention is Name Surname (Name Surname in Local Language) (Country)
    eg: Akibara Tanosuke (秋原太之助) (Asia Pacific)

    the profile picture generated then is A原 which looks unprofessional and weird.

    is there a way to manage the Profile picture without uploading a photo.

    1 vote
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  18. 1 vote
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  19. OpenID Connect sub claim should be consistent

    Currently the access token and id token that are issued have different "sub" claims even though the token request is for the same application registration...and the same request. This doesn't seem to match with the documentation and seems wrong. Can this be fixed please?

    2 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  20. Email is required to activate a sandbox

    I'm connected to the learning site, doing the Azure fundementals exercices, but cannot run the sandbox. I get the message 'Email is required to activate'.
    Please help

    1 vote
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
← Previous 1 3 4 5
  • Don't see your idea?

Feedback and Knowledge Base