Azure portal

The Azure Portal a central place where you can provision, manage and monitor your Azure resources. From the Azure Portal you can create any of the thousands of items within the Azure Marketplace, you can quickly navigate to resources and accomplish your administrative needs, and you can build custom shareable dashboards to provide live insights into your deployed resources.

To gain early access to our latest features please make sure to visit the preview portal.
Preview.portal.azure.com is our early release soon to be in production.

Have any ideas or feature requests? We would love to hear your feedback! Don’t forget to follow us on Twitter to stay up to date on our latest updates @AzurePortal

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. Azure App Service HTTP requests to Azure VNet IP Addresses fail after upgrading to .NET 5.0

    (I reported this issue at https://github.com/dotnet/runtime/issues/44686, but they currently think it might be an issue on the Azure side, and asked me to open a bug report here.)

    I have a Windows Azure App Service hosting an ASP.NET Core MVC application that makes HTTP requests to a Linux VM via an Azure VNet IP address. When I target netcoreapp3.1, the requests succeed. When I target net5.0, I get the following exception:

    System.Net.Http.HttpRequestException: An attempt was made to access a socket in a way forbidden by its access permissions. (10.1.0.4:80)
    ---> System.Net.Sockets.SocketException (10013): An attempt was made to access a…

    8 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    3 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  2. Some networks are not visible during network peering selection

    If you have 3 vnets, where 2 of this are in the same region and 1 in an other, the 2 vnets in the same region are sometimes not able to see each other in network peering. If you want to create a peering from vnet0 to vnet1 (same region), vnet1 is not visible. But vnet2 which is located in an other region, does show up.

    This is a bug which does also affect the official AZ-104 course lab in module 5 (Task 2.5).
    The workaround is to check "I know my resource ID" (check attached file). with this option,…

    5 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    1 comment  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  3. I can't see my resources on the Portal

    When I log into the portal I can't see my Resource Groups and other resources that I created.

    I tried running an anonymous browser tab but it didn't work.

    Running Azure CLI "az group list" show everything, and I can perform all the operations.

    From the summary in the Portal I can see my apps etc, but I can't browse them anywhere, even in the "All Resources" blade the list is empty.

    Please see my attached files where I show the problem.

    4 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  4. Improve localization of Application Insights

    General availability of workspace-based Application Insights.

    An incorrect japanese translation of Application Insights.
    No need to show preview.

    Resouce Mode of workspace-base.
    ・Correct : "ワークスペースベース"
    ・Incorrect : "ワークスペースベース(プレビュー)"

    1 vote
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  5. The question mark on the navigation bar can be better.

    I found the question mark on the top navigation bar looks like a file cannot be found.
    Maybe the question mark can be replaced with an icon surrounded by a circle or a book icon, then the user can easily know that it means "tutorial" or "help".
    Thanks.

    1 vote
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  6. Dashboard with custom timestamp not work properly

    I want to create tile which show chart for for n th day from today's day.

    On Query analyzer, it's working fine but when I pin that query as dashboard it show No data for the given query.

    Sample query as below:

    union (traces)
    | where timestamp > ago(8d) and timestamp < ago(7d)
    | extend itemType = iif(itemType == 'availabilityResult',itemType,iif(itemType == 'customEvent',itemType,iif(itemType == 'dependency',itemType,iif(itemType == 'pageView',itemType,iif(itemType == 'request',itemType,iif(itemType == 'trace',itemType,iif(itemType == 'exception',itemType,"")))))))
    | where ((itemType == 'trace' or (itemType == 'request' or (itemType == 'pageView' or (itemType == 'customEvent' or (itemType == 'exception' or (itemType == 'dependency' or itemType ==…

    1 vote
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  7. Bug using Query Work Items task

    We use the Query Work Items task in a pipeline to check our tasks for misconfiguration.

    Running the pipeline we get results back and the pipeline still succeeds. We left the MIN and MAX thresholds empty, as the default values are 0. We'd expect the pipeline to fail.

    Below is a sample how we use the task:


    • task: queryWorkItems@0
      inputs:
      queryId: some-query-id

    see: https://docs.microsoft.com/de-de/azure/devops/pipelines/tasks/utility/work-item-query?view=azure-devops

    2 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  8. Issue with deletion of Role when SPN is deleted

    In the scenario wherein an SPN having role assigned over a subscription, if the SPN is deleted the Role doesn't get deleted. It remains as a dangling role as shown

    1 vote
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  9. Issue with deletion of Role when SPN is deleted

    In the scenario wherein an SPN having role assigned over a subscription, if the SPN is deleted the Role doesn't get deleted. It remains as a dangling role as shown

    1 vote
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  10. “ Search for users V2 “ connector is known to fetch all the users when the search term returns a null value.

    “ Search for users V2 “ in the office 365 users connectors returns unintended users if the search term is a name column specified in a sharepoint list. If by chance user fails to fill the Name column,the search for users V2 takes this as null and fetches huge list of users from the azure AD . If the next step in flow is to send a mail, then mail will be triggered to all the users fetched by the connectors.

    This seems to be a not intended behaviour, because if the search term returned is null, the “ Search…

    3 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  11. Azure IA gallery: export an experiment

    Hello,
    I'm trying to export from Azure IA Gallery an experiment made by the community to my Azure ML Studio, but when I click on the button "Open in Studio (classic)" nothing happens (using Chrome & Safari).

    1 vote
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  12. Typo in description for Create ExpressRoute

    The description shown for the "Basic" setup for Create ExpressRoute contains a typo. It says "Excahnge provider", which probably should be "Exchange provider". See screenshot.

    1 vote
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  13. remove tags from extrenal solutions?

    If you assign a tage to an external solution by mistake, this can not be removed. The icon is grayed-out. Currenly you can only trop the solution and recreate this with the correct tag. (this wotks for azure managed resources).

    1 vote
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  14. Problem with creating Twitter identity provider on B2C tenant

    While creating identity provider as Twitter on B2C tenant, there is wierd callback URL adres (screen in attachment):

    https://b2cteam.b2clogin.com/b2cteam.onmicrosoft.com/your-user-flow-id/oauth1/authresp

    The provider is not functional after creation of course. Also this address can not be changed.

    Every other provider have this address exatly:

    https://b2cteam.b2clogin.com/b2cteam.onmicrosoft.com/oauth2/authresp

    I would expect this address on Twitter configuration too.

    I also tried another B2C tenant which has the same problem just with Twitter.

    Thanks for feedback.

    1 vote
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  15. App Services Deployment Center Security Bug

    There's a current security loophole in your system where if someone provides a link to the current Deployment Center, a user that does not have write permission but have read permission will be able to view the logs. They do not seem to have access to click on the buttons, but they might be able to see other parts they shouldn't have access to.

    Steps to replicate:
    1) Login as a user with read-only permissions
    2) Have a user with both write and read permission provide a link to the Deployment center
    3) User with read-only permission will be…

    1 vote
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  16. Error: Error while loading extension Microsoft_Azure_ActivityLog: EnvironmentFetchFailed

    Whenever I try access any resource on azure portal, either Storage, or even a subscription or resource group or even creating a support request page, i get error: ErrorLoadingExtensionAndDefinition
    With it I get a message to refresh my browser to try again but the error persists.

    The Details section has the message:
    Error: Error while loading extension <Any extension name>: EnvironmentFetchFailed

    2 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  17. Limitations on Privileged role administrator's rights.

    I recently tested which rights a "Privileged role administrator" because it's the only role (except Global Administrator) which gives access to managing Administrative units in Azure AD. When testing these rights I noticed that a "Privileged role administrator" has the ability to manage assignment of all Azure AD roles up to and including "Global administrator", something which in my opinion partially defeats the purpose of the role as it makes it quite simple to circumvent the limitations in place and gain Global administrator oneself.

    1 vote
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  18. 1 vote
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  19. Custom Domain in Azure web app bug

    I created a Web app, using Basic Paid plan (a classic nodejs app in linux machine in West Europe).
    I added a custom domain and a certificate. At some point I downgraded the app to the Free Plan and created a new Web App (Paid Plan). I wanted to add to the new app, the previous Custom Domain. I could not tho, because azure wanted me to remove the custom domain from the previous app. I could not do that also tho, because the app is now using Free Plan and I had no access to the custom subdomain and…

    1 vote
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  20. Sandbox created resources not visible in to the Azure portal in same account

    Hi Team, I have created resources through sandbox CLI but it doesn't reflect when I log in to the Azure portal and still can see default directory account type not Learning

    But same can be seen by using az network vnet list --output table in sandbox

    1 vote
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
← Previous 1 3 4 5 6
  • Don't see your idea?

Feedback and Knowledge Base