Azure portal

The Azure Portal a central place where you can provision, manage and monitor your Azure resources. From the Azure Portal you can create any of the thousands of items within the Azure Marketplace, you can quickly navigate to resources and accomplish your administrative needs, and you can build custom shareable dashboards to provide live insights into your deployed resources.

To gain early access to our latest features please make sure to visit the preview portal.
Preview.portal.azure.com is our early release soon to be in production.

Have any ideas or feature requests? We would love to hear your feedback! Don’t forget to follow us on Twitter to stay up to date on our latest updates @AzurePortal

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. In browser hold and drag (select) accidentally reveals previous page

    In portal:
    1. Search for "Policy"
    2. Start creating a new Policy definition
    3. Press mouse button in some empty space or inside Category text box
    4. Without releasing mouse button drag selection to the left, and keep dragging, like you normally do to select some text.

    Observe:
    You'll see that previous content/page starts to appear on the left. In my case list of all defined policies.

    If you drag far enough, you'll see an entire previous content.

    1 vote
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  2. Random Profile Picture Azure Generates not professional.

    The Random Profile Picture Azure generates when a users does not use a photo has some issues,

    we have users in Asian Countries that get like 1 English Alphabet then 1 native Language combined, which looks weird and unprofessional.

    Our Naming convention is Name Surname (Name Surname in Local Language) (Country)
    eg: Akibara Tanosuke (秋原太之助) (Asia Pacific)

    the profile picture generated then is A原 which looks unprofessional and weird.

    is there a way to manage the Profile picture without uploading a photo.

    1 vote
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  3. One #$SDFSDF^SDF#@CSW#$%#$ account per email address??? Like everyone else in the world????

    Your whole "switch directories" work account or other? is so complicated, so convoluted, I can't even begin

    2 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  4. Access/permission related issues in Azure Storage Explorer which is not seen in Azure Storage Explorer downloaded version

    Access/permission related issues in Azure Storage Explorer which is not seen in Azure Storage Explorer downloaded version. Firewall rules and access permission issues seen or not reflecting promptly.

    2 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  5. 1 vote
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  6. Blueprint w/ARM artifact w/securestring parameter breaks UI

    According to this link (below), it is possible to specify an ARM artifact for an Azure Blueprint, within which 1+ parameters reference securestring values from an Azure KeyVault.

    https://github.com/Azure/azure-rest-api-specs/blob/master/specification/blueprint/resource-manager/Microsoft.Blueprint/preview/2018-11-01-preview/blueprintDefinition.json

    Specifically, see the "SecretValueReference" entity schema and it's corresponding relationship to the ARM artifact schema.

    However, when defining a Blueprint with such attributes, it causes the blueprint blade to fail for that blueprint. Interestingly, the blades to edit the Blueprint and/or assign the Blueprint still work as expected.

    To recreate, create an Azure Blueprint that includes an ARM template artifact. The ARM template artifact should load a securestring from a Key…

    2 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    2 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  7. Email is required to activate a sandbox

    I'm connected to the learning site, doing the Azure fundementals exercices, but cannot run the sandbox. I get the message 'Email is required to activate'.
    Please help

    1 vote
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  8. PushRequest should be able to be created from Repository names with /äü etc

    Currently, it's possible to automatically create pull requests in a ticket. That works fine when the name of the repository doesn't have special characters like / and ä or ü but unfortunately the process fails when such a character is in there.

    1 vote
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  9. Make the Azure Portal actually work. I can't follow any tutorials in the learn section.

    All learn tutorials have directions that don't work. My account can't even register the Microsoft.Web resource provider. It just stays stuck at registering or unregistering. Can't proceed to make a chat bot or anything due to this.

    1 vote
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  10. application gateway

    Hello,

    We believe we have identified a bug within the Azure Portal.

    See steps below:


    1. Go to the Azure Application Gateway service

    2. Click on any current Application Gateway

    3. Go to the HTTP settings section and then click on the current config set, the port number changes to the default HTTP port of 80, instead of keeping the port that is already configured.

    In our case, we were going into the configurations section to only adjust the timeout value, not the port, the port was automatically changed and this caused a temporarily outage as we did not realize until afterwards that…

    1 vote
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  11. Login to Azure Portal

    Couldn't log into Azure Portal for some time, and no way to create incident ticket without login in. Is it just me?

    1 vote
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  12. Please fix azure functions portal. It is insanely slow!

    Loading azure function apps and list of functions takes minutes!!

    1 vote
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  13. Azure App Service and HttpContext.RequestAborted Cancellation Token

    I have a dotnet core 3.1 application that is computational intensive, i.e. response for request might delay for a few minutes, accordingly I am monitoring the FIN or HttpContext.RequestAborted,

    Lets say an example of code would be

    public async Task<IActionResult> Get(string request)
    {

      await _process.IntensiveTaskAsync(HttpContext.RequestAborted);
    
    return Ok();

    }
    Now that works fine in many environments include linux, IIS, nginx (proxy) .. Meaning that my "IntensiveTaskAsync" will orderly terminated on CancellationToken (i.e. User terminate the request) .. However when the code now is hosted in Azure Web App from Container (linux) it doesn't work. Is there any configuration required for that…

    2 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  14. Operation name under Run History for VMSS is Not accurate

    Bug: Operation name under Run History for Virtual Machine Scale Set (VMSS) says scale up and down whereas it should say scale in and out. E,g. Operation name when you scroll down on Run History says "Autoscale scale down completed" or "Autoscale scale up completed". This is technically NOT correct. The operation is actually "Scaling In" and "Scaling Out". Scaling up means increasing the number of vCPUs and Memory whereas scaling out means increasing the number of instances.

    1 vote
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  15. Fix subscription financial management features for AAD B2B users

    When a subscription is linked to an AAD directory where the subscription Account Admin is not a "native" user, but instead a used added via AAD B2B from another directory, certain financial management features in the Azure Portal display "access denied" or "unauthorized" messages instead of working properly.
    These features include:
    - payment methods
    - invoices
    - adding credits to an OPEN subscription

    This is a sample setup where the problem appears:
    1. An organization has multiple AAD directories:
    a) the main, "office" AAD directory, where all user accounts are created,
    b) several AAD directories assigned to specific products and/or…

    5 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  16. Issues With Sandbox Activation (Microsoft Learning)

    When I activate a sandbox on Microsoft learning, every time I need to refresh the browser refresh to reflect the resourcegroup/ resources etc to be listed on the page. If I click the refresh button on top of the bar inside the each of the pages, it doesn't list.

    10 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    28 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  17. Azure user profile picture not getting changed across all connected services

    Steps to reproduce bug as an end user.
    Prerequisite: User account should have profile photo(Which is set first time)

    1) Open any portal/site where AD user can change his/her profile picture.

    Eg <a rel="nofollow noreferrer" href="https://portal.office.com/account/#personalinfo">https://portal.office.com/account/#personalinfo</a>
    

    2) Upload your new photo
    3) On office portal and Azure portal new photo is immediately updated.
    4) New Photo is Not Updated on following areas

    a) https://account.activedirectory.windowsazure.com/r#/profile
    b) PowerApps >> Canvas App >> User().Image
    c) MS Office desktop applications >> Account section(see attached file Err-1.png)

    Notes:
    1) Even after 2 months period of time photos not getting changed
    2) On browsers all caches/cookies…

    4 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  18. 1 vote
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  19. When updating an HTTP setting the Backend port value is reset in the Portal

    If I have an existing Azure Application Gateway HTTP setting using Backend port 8080 and I edit that Setting the value in the "Backend port" text box is reset to 80 when the blade appears (possibly when the radio button above it loads, and the HTTP selection triggers the text box value to be set to 80?)
    The value of 8080 is shown in the preceeding list and confirmed by using PowerShell Get-AzApplicationGatewayBackendHttpSettings

    1 vote
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  20. Fix endless log-in loop using Internet Edge

    When using Internet Edge and trying to reach portal.azure.com or preview.portal.azure.com it asks you for an account as per usual (I have multiple, personal, multiple work accounts for different clients etc).
    Once having selected an account and entered password, one of three things will happen (both bugs):


    • Either it will try to log in endlessly, shifting between urls and continue to reload

    • It will try to log in a LOT of times, shifting between urls and eventually throw you back to the account selection window with no notice of what went wrong

    • It will show a white window, then back…
    2 votes
    Sign in
    (thinking…)
    Sign in with: Microsoft
    Signed in as (Sign out)

    We’ll send you updates on this idea

    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  • Don't see your idea?

Feedback and Knowledge Base