How can we improve Azure Virtual Machines?

Add word "Local" to the reserved words list for username when creating Windows VMs in Azure

When creating VMs, if you use the username "local" and choose a password the user account 'local' does not get created on the OS. Instead, the Administrator account gets enabled and the password you attempted to set for a user called "local" is set on the Administrator account.

This caused confusion during RDP to the OS, as the expected username to use was "local" - however, the account does not exist on the OS.

A potential fix would be to block the use of "local" as a username, similarly to how the username "Administrator" is reserved from use.

1 vote
Sign in
(thinking…)
Sign in with: Microsoft
Signed in as (Sign out)

We’ll send you updates on this idea

Craig Colley shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

Thanks for the valid suggestion. Your feedback is now open for the user community to upvote which allows us to effectively prioritize your request against our existing feature list and also gives us insight into the potential impact of implementing the suggested feature

0 comments

Sign in
(thinking…)
Sign in with: Microsoft
Signed in as (Sign out)
Submitting...

Feedback and Knowledge Base