We welcome user feedback and feature requests!

Enable HTTP/2 on Azure Web Apps

IIS 10.0 in Windows 10 already supports HTTP/2, Azure Web Apps should support it as well.

3,111 votes
Vote
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    Martin Suchan shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →
    completed  ·  AdminAzure App Service Team (Admin, Microsoft Azure) responded  · 

    Marking as complete! Full deployment for all multi-tenant resources is now complete. Enabling HTTP/2 is documented in the blog here:
    https://blogs.msdn.microsoft.com/appserviceteam/2018/04/13/announcing-http2-support-in-azure-app-service/

    We will have UI support in the Azure Portal in the coming weeks for a simple toggle experience but you can update through the resource explorer right now.

    Deployment to App Service Environmentx and national clouds will be coming shortly.

    Please reach out over the developer forums for any questions or issues encountered.

    Thanks,
    Oded

    152 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      Signed in as (Sign out)
      Submitting...
      • AdminAzure App Service Team (Admin, Microsoft Azure) commented  ·   ·  Flag as inappropriate

        @Bede, I'll follow up directly over email. We were able to configure HTTP2 for Dejan on our side, but still don't understand why there is problem from yours.

        Please make sure the precise path is followed in resource explorer and that you are in read/write mode when trying to save.

        Thanks,
        Oded

      • Bede commented  ·   ·  Flag as inappropriate

        I see the same behavior as @Dejan. http20enabled property doesn't exist in any of my app service resources, and attempting to add it with PUT results in it not persisting.

      • Hernan M. commented  ·   ·  Flag as inappropriate

        I found it under subscriptions/mysitename/resourcegroups/myresourcegroup/providers/microsoft.web/sites/mysitename/config/web

      • Dejan commented  ·   ·  Flag as inappropriate

        http20enabled option is not there for me. I tried adding it to the config, but it just disappears after PUT.

      • Jenny Lawrance commented  ·   ·  Flag as inappropriate

        @Disco Dave, please send an email to me (jennylaw(at)microsoft.com with your sitename and how you reproduced this so that we can investigate your specific issue further.

      • AdminAzure App Service Team (Admin, Microsoft Azure) commented  ·   ·  Flag as inappropriate

        Thank you for the comments. We are still in the middle of deployments and recommend not to turn on HTTP/2 until we have confirmed we completed deployments. If there is any issue thereafter, we will deal with it through full support, not over the chat here.

        Thanks,
        Oded

      • Jeff Papp commented  ·   ·  Flag as inappropriate

        We are running into this issue and we tried to set "http20Enabled": false in resource explorer but our site is still serving up http/2. Is there anything else we need to configure to disable this?

      • Anonymous commented  ·   ·  Flag as inappropriate

        An XHR request to a json file results in an SDPY error in chrome for me with http20enabled=true. This came on without any deployment

      • Dennis Micheelsen commented  ·   ·  Flag as inappropriate

        I have a number of sites in West Europe, and they have http20enabled=true, but the sites is still responding with http/1.1

        Restarting the sites does not help.

        Can I do something, or should I just wait for MS to flip some bits?

      • Disco Dave commented  ·   ·  Flag as inappropriate

        @Azure App Service Team. We have just spent the last 2 days trying to resolve an issue with sporadic 503 requests with static resources on our web app. (Usually 3 requests per page view out of around 40).

        This is slightly different to the other comments mentioned and we can reproduce at will,
        Turning of HTTP/2 via resource explorer fixed the problem.

        If you want to get to the bottom of this or need more info, please give me a shout.

      • Conor M commented  ·   ·  Flag as inappropriate

        Oded - during the incident we put Cloudflare in front of our API and it solved the problem. It seems their implementation of HTTP2 plays well with the OkHttp client.

      • Oded Dvoskin - Microsoft commented  ·   ·  Flag as inappropriate

        Thanks all for confirming. We have paused the deployment in the regions impacted by this issue. We will look at what best way to proceed. Seems there is an edge case which doesn't work with HTTP/2.

      • Jim commented  ·   ·  Flag as inappropriate

        Oded's solution helped us to resolve the issue, thank you Oded!

      • Jim commented  ·   ·  Flag as inappropriate

        Ditto on Gunnstein and Oded...we've been directed to do this via MS...we're about to do this in production and will relay the results once completed...

      ← Previous 1 3 4 5 6 7 8

      Feedback and Knowledge Base