We welcome user feedback and feature requests!

[Linux Containers] Permit port numbers in private registry image names

When trying to use an image from a private registry, the portal does not allow specifying a port number. A port number is valid tough, see https://docs.docker.com/engine/reference/commandline/tag/:

"An image name is made up of slash-separated name components, optionally prefixed by a registry hostname. The hostname must comply with standard DNS rules, but may not contain underscores. If a hostname is present, it may optionally be followed by a port number in the format :8080"

1 vote
Vote
Sign in
(thinking…)
Sign in with: oidc
Signed in as (Sign out)
You have left! (?) (thinking…)
Christina shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

3 comments

Sign in
(thinking…)
Sign in with: oidc
Signed in as (Sign out)
Submitting...
  • Christina commented  ·   ·  Flag as inappropriate

    Also, just to note: I _can_ put a port number into the registry URL field in the portal. It doesn't make any sense at all to not permit it in the image name, which needs to match to the hostname and port from the registry URL.

  • Christina commented  ·   ·  Flag as inappropriate

    Ahmed, note that I am the same person asking for the bug to be fixed in the portal as well as providing the workaround in a comment. I am not asking for fields or functionality to be added.

    This is simply a bug in the validation of the input field. An image name is valid if it contains a port number, but the portal claims it is invalid.

  • Christina commented  ·   ·  Flag as inappropriate

    This is a portal issue only, things work fine using the Azure command line (az webapp config container set...).

Feedback and Knowledge Base